Bug 1817 - we set the localmachine name to the clients ip_addr when it sends *SMBSERVER or *SMBSERV
we set the localmachine name to the clients ip_addr when it sends *SMBSERVER ...
Status: RESOLVED DUPLICATE of bug 1519
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.7
All Windows XP
: P3 minor
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-24 01:21 UTC by Stefan Metzmacher
Modified: 2004-09-24 05:32 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Metzmacher 2004-09-24 01:21:03 UTC
we set the localmachine name to the clients ip_addr when it sends *SMBSERVER or
*SMBSERV

in lib/substitude.c set_local_machine_name():

if ( strequal(tmp_local_machine, "*SMBSERVER") || strequal(tmp_local_machine,
"*SMBSERV") )  {
	fstrcpy( local_machine, client_socket_addr() );
	return;
}


this sound be the local ip not the one from the client!

comment from tridge on irc:
<@tridge> but as clients mostly use 445 now, this stuff is almost useless
<@tridge> we need to get the server name from session setup
Comment 1 Gerald (Jerry) Carter 2004-09-24 05:32:57 UTC

*** This bug has been marked as a duplicate of 1519 ***