Bug 1786 - Bug in representation of filename under MS DOS & Win 9x
Bug in representation of filename under MS DOS & Win 9x
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Extended Characters
3.0.7
x86 Windows 98
: P3 critical
: none
Assigned To: Alexander Bokovoy
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-16 23:32 UTC by Alexander Morgun
Modified: 2005-08-24 10:22 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Morgun 2004-09-16 23:32:23 UTC
I have the next computers in my NetWork:
Workstation (MS-DOS v6.22 and Microsoft Network Client v3.0 for MS-DOS) and 
erver (Linux RH9.0 and Samba 3.0.7).

The problem is:
When Workstation tries to creat a file on Network Drive with the name 
containing symbols like !, @, %, ^, &, (, ), {, }, ', `, # I get on 
Workstation the name of file like this ______~4. 
But, if I look at the name of the created file from Linux Consol I will see 
the correctly name of this file. 

As above the problem is observing under Win9x.
There is no promlems if I use WinXP.
Comment 1 Alexander Bokovoy 2005-01-13 01:22:51 UTC
Please attach your smb.conf configuration (sans sensitive information) and
information about language settings on your Windows boxes.
Comment 2 Gerald (Jerry) Carter 2005-02-12 07:43:08 UTC
no reply in a month.  please retest against 3.0.11.  Thanks.
Comment 3 Gerald (Jerry) Carter 2005-08-24 10:22:17 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.