Bug 1772 - samba 3.0.6 breaks use of smbusers
samba 3.0.6 breaks use of smbusers
Product: Samba 3.0
Classification: Unclassified
Component: winbind
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2004-09-15 09:21 UTC by Terry
Modified: 2005-08-24 10:26 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Terry 2004-09-15 09:21:23 UTC
ive upgraded to samba 3.0.6 (from 3.0.5) and it seems that it has some issues 
with  username map. i use username map = /etc/samba/smbusers which maps NT 
domain users to local users in form:
zbych = PWDNT\zbyszek

(PWDNT is Win's domainname)

with samba 3.0.5 everything works as expected, domain user zbyszek gets access 
to samba as zbych.
with samba 3.0.6 though, it looks as if smbusers file was simply ignored. 
domain user zbyszek gets connected as PWDNT\zbyszek and in turn does not get 
zbych's permission to access shares.

i tried using different combinations (PWDNT\zbyszek, pwdnt/zbyszek etc) to no 
downgrade to 3.0.5 resolves the issue.

i also tried upgrading to 3.0.7 but with same effect.
Comment 1 Gerald (Jerry) Carter 2004-10-25 10:46:37 UTC
This is fixed in the upcoming 3.0.8.  Please test the latest SAMBA_3_0 
svn code or wait for 3.0.8pre2
Comment 2 Terry 2004-10-26 01:49:42 UTC
THANK you very much for the fix. I'll test it as soon as pre version is out :)
Comment 3 Eral Trmb 2005-01-05 18:43:55 UTC
Please reopen.

I sincerely doubt this is fixed, or let's say it has been broken again.

/etc/samba/smbusers is ignored and users having a different linuxID and smbID
cannot authenticate. This is true for security = user and security = domain.

This problem exists in Suse 9.1 samba-3.0.9, Fedora C3 samba-3.0.10 and Mandrake
cooker samba-3.0.10.

Fedora C3 samba-3.0.8-0.pre1.3 works fine:

Comment 4 Gerald (Jerry) Carter 2005-01-05 20:29:39 UTC
Eral, adding comments to closed bugs is not a good idea.
And I notice that you are actually misinterpreting the logs files
in the Redhat bug report.  Please open a new bug and include
your smb.conf, username map file and level 10 debug log of a failure.
Comment 5 Terry 2005-01-06 03:02:00 UTC
for me it works like a charm (samba 3.0.8 compiled off the gentoo linux ebuild)
Comment 6 Eral Trmb 2005-01-06 13:48:11 UTC
As I said, Fedora C3 3.0.8 works fine but 3.0.9 and 3.0.10 break with the same
config files. Created new report #2219:

Comment 7 Gerald (Jerry) Carter 2005-08-24 10:26:34 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.