Bug 1766 - Wrong filenames or unusable SWAT
Wrong filenames or unusable SWAT
Product: Samba 3.0
Classification: Unclassified
Component: Extended Characters
Sparc Solaris
: P3 normal
: none
Assigned To: Alexander Bokovoy
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2004-09-15 04:53 UTC by Frank Giessler
Modified: 2005-08-24 10:19 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Frank Giessler 2004-09-15 04:53:22 UTC
I searched the bugzilla database but couldn't find any solution that worked for
me. Here's the setup I'm using:

Samba 3.0.7 running on Solaris 9 (SPARC)
Client is W2k

When using default values for character sets, i.e.:

   dos charset = CP850
   unix charset = UTF-8
   display charset = LOCALE

then I can't use SWAT (on W2k) because the page is corrupt like this:

Button "Speichere Änderungen" is "Speichere _nderungen"
Button "Setze Werte zurück" is "Setze Werte zur_ck".

Filenames are ok from W2k but unusable from Solaris.

If I change the settings to values I prefer:

   dos charset = CP850
   unix charset = LOCALE
   display charset = LOCALE

SWAT becomes usable but the filenames are wrong:

If I copy file "überfäll" from a local W2k disk to a samba share it becomes
"|berfdll" (seen from both W2k and Solaris).

I ran out of ideas. If there is a solution to this it seems to be well hidden.
Comment 1 Björn Jacke 2004-09-28 04:44:35 UTC
this is fixed in svn. There is used utf-8 now for html output everywhere, with
the recommended unix charset = utf-8 there should be everything fine now.
Comment 2 Gerald (Jerry) Carter 2005-08-24 10:19:25 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.