Bug 1760 - Samba 3.0.6 compile failure on Tru 64 Unix 4.0f
Samba 3.0.6 compile failure on Tru 64 Unix 4.0f
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.6
Alpha OSF/1
: P3 regression
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-14 12:02 UTC by Scott McAskill
Modified: 2005-08-24 10:17 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scott McAskill 2004-09-14 12:02:48 UTC
Using default cc compiler on a Tru 64 Unix (formerly OSF/1)4.0f alphaserver the 
compilation fails as follows:

.
.
.
Compiling modules/vfs_extd_audit.c with -fPIC
Building plugin bin/extd_audit.so
ld:
Warning: Unresolved:
dbgtext
dbghdr
DEBUGLEVEL_CLASS
DEBUGLEVEL_CLASS_ISSET
debug_add_class
smb_register_vfs
Compiling modules/vfs_full_audit.c with -fPIC
cc: Error: modules/vfs_full_audit.c, line 140: In this declaration, the type of
"audit_lock" is not compatible with the type of a previous declaration of "audit
_lock" at line number 1699 in file /usr/include/prot.h. (notcompat)
static BOOL audit_lock(vfs_handle_struct *handle, files_struct *fsp, int fd,
------------^
cc: Error: modules/vfs_full_audit.c, line 1116: In this declaration, the type of
 "audit_lock" is not compatible with the type of a previous declaration of "audi
t_lock" at line number 1699 in file /usr/include/prot.h. (notcompat)
static BOOL audit_lock(vfs_handle_struct *handle, files_struct *fsp, int fd,
------------^
*** Exit 1
Stop.
#
Comment 1 Tim Potter 2004-09-14 16:41:32 UTC
Did this work for any of the previous 3.0 builds?

Can you suggest a link line that fixes the problem?  Unfortunately we don't have
direct access to any tru64 machines to test things out.
Comment 2 Scott McAskill 2004-09-15 04:17:56 UTC
(In reply to comment #1)
> Did this work for any of the previous 3.0 builds?
> Can you suggest a link line that fixes the problem?  Unfortunately we don't 
have
> direct access to any tru64 machines to test things out.

Yes, I've used Samba seemlessly for years and am currently running version 
3.0.5. I just downloaded 3.0.7 and will try to build that today. My first 
thought was that the problem may be related to the fact that the OS version is 
getting dated. (As an aside, an OS upgrade to Tru 64 version 5.x has been on 
hold because the primary application on the box won't support it. That 
application has since been migrated to Windows so the OS upgrade is expected in 
the coming year). 

Anyway, by link line do you mean an additional library reference to pass to the 
linker?  
Comment 3 Tim Potter 2004-09-15 05:10:02 UTC
Oops - I misread the output you pasted in.  It obviously isn't a library linking
problem.

After some more research I have discovered that this bug has been fixed in
3.0.7.    Since 3.0.7 is a security release you should probably upgrade to it
instead of 3.0.6.
Comment 4 Scott McAskill 2004-09-15 11:40:34 UTC
(In reply to comment #3)
> Oops - I misread the output you pasted in.  It obviously isn't a library 
linking
> problem.
> After some more research I have discovered that this bug has been fixed in
> 3.0.7.    Since 3.0.7 is a security release you should probably upgrade to it
> instead of 3.0.6.

Many thanks. 3.0.7 compiled and installed cleanly.
Comment 5 Gerald (Jerry) Carter 2005-08-24 10:17:22 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.