Bug 1756 - Samba will not serve files.
Samba will not serve files.
Status: RESOLVED WORKSFORME
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.6
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-14 04:34 UTC by tarjei
Modified: 2004-10-12 02:40 UTC (History)
0 users

See Also:


Attachments
Log dump from one machine (204.05 KB, text/plain)
2004-09-14 04:45 UTC, tarjei
no flags Details
Logfile from trying to open a file via smb:// interface in kde (374.37 KB, text/plain)
2004-09-14 04:45 UTC, tarjei
no flags Details
Network sniff (654.22 KB, text/plain)
2004-09-14 04:46 UTC, tarjei
no flags Details
XP client trying to open file (298.89 KB, application/octet-stream)
2004-09-14 07:52 UTC, tarjei
no flags Details
Network sniff of linuxclient trying to download fil (220.19 KB, application/octet-stream)
2004-09-14 07:54 UTC, tarjei
no flags Details
Winclient logdump (211.97 KB, application/x-gzip)
2004-09-14 07:58 UTC, tarjei
no flags Details
Lin-client logdump (86.81 KB, application/x-gzip)
2004-09-14 07:58 UTC, tarjei
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description tarjei 2004-09-14 04:34:48 UTC
Hi, I just upgraded samba from 3.0.4 to 3.0.6 (tried .7 as well). I used the
exact same .spec file as I used for compilign 3.0.4. I also tried using SuSE's
official rpms with the same result:

Basicl, after the upgrade, the server will let the user log in, browse shares
and subfolders, but nor open files. Explorer on the clients becomes very slow
and crashes quite often.

The logs report very little. 

I'll attach some dumps soon.
Comment 1 tarjei 2004-09-14 04:45:29 UTC
Created attachment 651 [details]
Log dump from one machine
Comment 2 tarjei 2004-09-14 04:45:58 UTC
Created attachment 652 [details]
Logfile from trying to open a file via smb:// interface in kde
Comment 3 tarjei 2004-09-14 04:46:26 UTC
Created attachment 653 [details]
Network sniff
Comment 4 tarjei 2004-09-14 07:52:43 UTC
Created attachment 654 [details]
XP client trying to open file
Comment 5 tarjei 2004-09-14 07:54:31 UTC
Created attachment 655 [details]
Network sniff of linuxclient trying to download fil

Please notice that it stopps downloading after 16kb.
Comment 6 tarjei 2004-09-14 07:58:08 UTC
Created attachment 656 [details]
Winclient logdump
Comment 7 tarjei 2004-09-14 07:58:29 UTC
Created attachment 657 [details]
Lin-client logdump
Comment 8 webgurl 2004-10-11 16:44:26 UTC
  I had a similar problem between Samba 3.0.7 on Debian Sarge and Windows 2000.
 I fixed the problem by adding "use sendfile = no" in [global] and restarting my
Samba daemon.  Given that the release notes for 3.0.7 mention that Samba now
turns on sendfile by default for non-Win9x clients I assume the problem is related.
Comment 9 tarjei 2004-10-12 02:40:59 UTC
Yep, this was the sendfilebug.