Bug 1727 - Redefinition of 'struct statfs'
Redefinition of 'struct statfs'
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.6
s390 Linux
: P3 major
: none
Assigned To: Jim McDonough
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-06 18:35 UTC by Alton
Modified: 2004-11-22 11:42 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alton 2004-09-06 18:35:34 UTC
I compiled Samba following the instruction 
in "http://us4.samba.org/samba/docs/man/Samba-HOWTO-
Collection/compiling.html".  I ran "./configure" with the option "./configure --
with-acl-support=yes --with-ads=yes".  The result was fine.  Then, I issue the 
command "make".  Error occured as follow:

Using FLAGS =  -O -I/usr/include/heimdal -I./popt -Iinclude -
I/tmp/smb_inst/samba-3.0.6/source/include -I/tmp/smb_inst/samba-
3.0.6/source/ubiqx -I/tmp/smb_inst/samba-3.0.6/source/smbwrapper  -I. -
D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -
I/usr/include/heimdal -I/tmp/smb_inst/samba-3.0.6/source    
      LIBS = -lcrypt -lresolv -lnsl -ldl
      LDSHFLAGS = -shared -Bsymbolic 
      LDFLAGS = 
Generating smbd/build_options.c
Building include/proto.h
creating /tmp/smb_inst/samba-3.0.6/source/include/proto.h
Building include/wrepld_proto.h
creating /tmp/smb_inst/samba-3.0.6/source/include/wrepld_proto.h
Building include/build_env.h
creating /tmp/smb_inst/samba-3.0.6/source/nsswitch/winbindd_proto.h
creating /tmp/smb_inst/samba-3.0.6/source/web/swat_proto.h
creating /tmp/smb_inst/samba-3.0.6/source/client/client_proto.h
creating /tmp/smb_inst/samba-3.0.6/source/utils/net_proto.h
Compiling dynconfig.c
In file included from /usr/include/asm/statfs.h:6,
                 from /usr/include/linux/vfs.h:4,
                 from /usr/include/linux/fs.h:13,
                 from /usr/include/linux/capability.h:17,
                 from /usr/include/sys/capability.h:24,
                 from include/includes.h:347,
                 from dynconfig.c:21:
/usr/include/asm-s390/statfs.h:20: redefinition of `struct statfs'
make: *** [dynconfig.o] Error 1

The same error occured in several trials in my ZLinux in s390.  But everything 
was fine when I did the same thing in my x86 Linux.
Comment 1 Tim Potter 2004-09-06 18:51:55 UTC
Jim might have some ideas about what is happening here.
Comment 2 Jim McDonough 2004-11-22 11:42:41 UTC
This is a problem you should bug SuSE about...asuming you're using SuSE. 
There's not much we can do about it.  Please see:

http://www2.marist.edu/htbin/wlvtype?LINUX-VM.41455