Bug 1725 - Signal 11 when trying to run SWAT
Signal 11 when trying to run SWAT
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: SWAT
3.0.6
x86 other
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-06 09:41 UTC by Tim Boyer
Modified: 2005-08-24 10:19 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Boyer 2004-09-06 09:41:48 UTC
Upgrading from 2.2.11 to 3.0.6 on dg/ux.  smbd works fine; swat fails with an
internal panic.  Running dbx on swat gives me

# /etc>dbx /usr/local/samba/sbin/swat core
Type "help" for a list of commands
ELF corefile process information:
  UID   GID   PID  PPID  PGID   SID     SZ COMMAND
    0     1  9408  4283  4283  4283    175 swat
Created on system: dgux dg R4.20MU05 generic AViiON
 
Processing object: /usr/local/samba/sbin/swat
Updating linker symbol table...3034 symbols added. (Total: 3034)
Updating symbolic debugging information...0 modules added. (Total: 0)
Processing object: /usr/dglib/libc.so.1
Updating linker symbol table...1862 symbols added. (Total: 4896)
Updating symbolic debugging information...0 modules added. (Total: 0)
Processing object: /usr/dglib/libresolv.so.1
Updating linker symbol table...41 symbols added. (Total: 4937)
Updating symbolic debugging information...0 modules added. (Total: 0)
Processing object: /usr/dglib/libsocket.so.1
Updating linker symbol table...128 symbols added. (Total: 5065)
Updating symbolic debugging information...0 modules added. (Total: 0)
Processing object: /usr/dglib/libnsl.so.1
Updating linker symbol table...568 symbols added. (Total: 5633)
Updating symbolic debugging information...0 modules added. (Total: 0)
Stopped at pc 0x8003f168 (_kill+12)
*       0x8003f168 _kill+12     jb      __dg_sh_cerror
 core-dump-requested
 caught signal 6, SIGABRT, abnormal termination, e.g., by abort() -  (core dumpe
d)
(dbx) where
Frame 0, pc 0x8003f168 (_kill+12)
Frame 1, pc 0x80bb65f (smb_panic2+399)
Frame 2, pc 0x80bb4c0 (smb_panic+16)
Frame 3, pc 0x80a822d (dbgtext+413)
Frame 4, pc 0x80a828e (dbgtext+510)
Frame 5, pc 0x8006bc25 (__sigacthandler2+33)
Frame 6, pc 0xffffffff (__libnsl_threads_routines+2146638559)
Frame 7, pc 0x80c6faa (smb_register_charset+506)
Frame 8, pc 0x80c70ce (smb_iconv_open+14)
Frame 9, pc 0x80a553b (init_iconv+43)
Frame 10, pc 0x80577f9 (lp_load+617)
Frame 11, pc 0x804dbec (status_page+4780)
Frame 12, pc 0x804fed2 (main+242)
Frame 13, pc 0x804ad69 (_start+105)
(dbx) quit

The log looks like so:

# /usr/local/samba/var>cat log.swat
[2004/09/06 12:04:21, 5] lib/debug.c:debug_dump_status(367)
  INFO: Current debug levels:
    all: True/10
    tdb: False/0
    printdrivers: False/0
    lanman: False/0
    smb: False/0
    rpc_parse: False/0
    rpc_srv: False/0
    rpc_cli: False/0
    passdb: False/0
    sam: False/0
    auth: False/0
    winbind: False/0
    vfs: False/0
    idmap: False/0
    quota: False/0
    acls: False/0
  doing parameter syslog = 10
  doing parameter log file = /var/log/samba/%m.log
  doing parameter time server = Yes
  doing parameter deadtime = 15
  doing parameter os level = 33
  doing parameter preferred master = Yes
  doing parameter domain master = Yes
  doing parameter wins proxy = Yes
  doing parameter wins support = Yes
  doing parameter remote announce = 192.168.0.255/WINDOWS
  doing parameter hosts allow = 192.168.
[2004/09/06 12:04:21, 2] param/loadparm.c:do_section(3421)
  Processing section "[printers]"
  doing parameter comment = All Printers
  doing parameter path = /tmp
  doing parameter valid users = cliff angie sherry laptop stacie denmannt
        sharyn scott bill rick lloyd
  doing parameter create mask = 0700
  doing parameter printable = Yes
  doing parameter browseable = No
[2004/09/06 12:04:21, 2] param/loadparm.c:do_section(3421)
  Processing section "[tmp]"
  doing parameter comment = Temporary file space
  doing parameter path = /tmp
  doing parameter read only = No
  doing parameter guest ok = Yes
[2004/09/06 12:04:21, 2] param/loadparm.c:do_section(3421)
  Processing section "[printouts]"
  doing parameter comment = Temporary file space
  doing parameter path = /printouts
  doing parameter read only = No
  doing parameter guest ok = Yes
[2004/09/06 12:04:21, 2] param/loadparm.c:do_section(3421)
  Processing section "[data]"
  doing parameter comment = Data path
  doing parameter path = /data
  doing parameter valid users = tim cliff laptop denmannt dad tboyer
  doing parameter read only = No
[2004/09/06 12:04:21, 2] param/loadparm.c:do_section(3421)
  Processing section "[sales]"
  doing parameter comment = Shared sales file
  doing parameter path = /home/sales
  doing parameter valid users = tim stacie angie jim sharyn cliff tboyer
  doing parameter read only = No
  doing parameter create mask = 0666
[2004/09/06 12:04:21, 2] param/loadparm.c:do_section(3421)
  Processing section "[kronos]"
  doing parameter comment = Shared time clock file
  doing parameter path = /home/kronos
  doing parameter valid users = tim pat lloyd lois scott sherry bill cliff
  doing parameter read only = No
  doing parameter create mask = 0666
[2004/09/06 12:04:21, 2] param/loadparm.c:do_section(3421)
  Processing section "[payroll]"
  doing parameter comment = Shared payroll file
  doing parameter path = /home/payroll
  doing parameter valid users = tim lloyd sherry gary scott
  doing parameter read only = No
  doing parameter create mask = 0666
[2004/09/06 12:04:21, 2] param/loadparm.c:do_section(3421)
  Processing section "[development]"
  doing parameter comment = development file for read/write
  doing parameter path = /home/development
  doing parameter valid users = tim cliff frank schedule george angie bob danny
tina
  doing parameter write list = tim cliff frank george tina
  doing parameter create mask = 0666
[2004/09/06 12:04:21, 2] param/loadparm.c:do_section(3421)
  Processing section "[lab]"
  doing parameter comment = Shared lab file
  doing parameter path = /home/lab
  doing parameter valid users = tim cliff frank bob george tina
  doing parameter read only = No
  doing parameter create mask = 0666
  doing parameter guest ok = Yes
[2004/09/06 12:04:21, 2] param/loadparm.c:do_section(3421)
  Processing section "[drawings]"
  doing parameter comment = Shared drawing file
  doing parameter path = /home/drawings
  doing parameter read only = No
  doing parameter create mask = 0666
  doing parameter guest ok = Yes
[2004/09/06 12:04:21, 2] param/loadparm.c:do_section(3421)
  Processing section "[iso]"
  doing parameter comment = Shared lab file
  doing parameter path = /home/tina/WSFILES/ISO9001
  doing parameter write list = tim cliff tina
  doing parameter create mask = 0666
  doing parameter guest ok = Yes
[2004/09/06 12:04:21, 2] param/loadparm.c:do_section(3421)
  Processing section "[labels]"
  doing parameter comment = Shared labels file
  doing parameter path = /home/labels
  doing parameter write list = tim cliff
  doing parameter create mask = 0666
  doing parameter guest ok = Yes
[2004/09/06 12:04:21, 2] param/loadparm.c:do_section(3421)
  Processing section "[mrtg]"
  doing parameter comment = MRTG httpd files
  doing parameter path = /home/httpd/mrtg
  doing parameter valid users = tim
  doing parameter read only = No
  doing parameter create mask = 0666
[2004/09/06 12:04:21, 2] param/loadparm.c:do_section(3421)
  Processing section "[plcdata]"
  doing parameter comment = plcdata files
  doing parameter path = /home/plcdata
  doing parameter valid users = plcdata tim
  doing parameter read only = No
  doing parameter create mask = 0666
[2004/09/06 12:04:21, 2] param/loadparm.c:do_section(3421)
  Processing section "[voicent]"
  doing parameter comment = voicent files
  doing parameter path = /home/voicent
  doing parameter valid users = voicent tim
  doing parameter read only = No
  doing parameter create mask = 0666
[2004/09/06 12:04:21, 2] param/loadparm.c:do_section(3421)
  Processing section "[homes]"
  doing parameter comment = Home Directories
  doing parameter path = /home/%u
  doing parameter valid users = tim cliff angie sherry laptop stacie sharyn denm
annt scott bill lois schedule frank gary tina bob pat lloyd plcdata rickshaw dan
ny george jeff electric pms2 ntservice corey voicent sherry1 jim
  doing parameter read only = No
  doing parameter create mask = 0750
[2004/09/06 12:04:21, 4] param/loadparm.c:lp_load(3942)
  pm_process() returned Yes
[2004/09/06 12:04:21, 10] param/loadparm.c:set_server_role(3851)
  set_server_role: role = ROLE_STANDALONE
[2004/09/06 12:04:21, 5] lib/iconv.c:smb_register_charset(95)
  Attempting to register new charset UCS-2LE
[2004/09/06 12:04:21, 5] lib/iconv.c:smb_register_charset(103)
  Registered charset UCS-2LE
[2004/09/06 12:04:21, 5] lib/iconv.c:smb_register_charset(95)
  Attempting to register new charset UTF8
[2004/09/06 12:04:21, 5] lib/iconv.c:smb_register_charset(103)
  Registered charset UTF8
[2004/09/06 12:04:21, 5] lib/iconv.c:smb_register_charset(95)
  Attempting to register new charset ASCII
[2004/09/06 12:04:21, 5] lib/iconv.c:smb_register_charset(103)
  Registered charset ASCII
[2004/09/06 12:04:21, 5] lib/iconv.c:smb_register_charset(95)
  Attempting to register new charset 646
[2004/09/06 12:04:21, 5] lib/iconv.c:smb_register_charset(103)
  Registered charset 646
[2004/09/06 12:04:21, 5] lib/iconv.c:smb_register_charset(95)
  Attempting to register new charset ISO-8859-1
[2004/09/06 12:04:21, 5] lib/iconv.c:smb_register_charset(103)
  Registered charset ISO-8859-1
[2004/09/06 12:04:21, 5] lib/iconv.c:smb_register_charset(95)
  Attempting to register new charset UCS2-HEX
[2004/09/06 12:04:21, 5] lib/iconv.c:smb_register_charset(103)
  Registered charset UCS2-HEX
[2004/09/06 12:04:21, 5] lib/iconv.c:smb_register_charset(95)
  Attempting to register new charset CP850
[2004/09/06 12:04:21, 5] lib/iconv.c:smb_register_charset(103)
  Registered charset CP850
[2004/09/06 12:04:21, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2004/09/06 12:04:21, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 6083 (3.0.6)
  Please read the appendix Bugs of the Samba HOWTO collection
[2004/09/06 12:04:21, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2004/09/06 12:04:21, 0] lib/util.c:smb_panic2(1385)
  PANIC: internal error
Comment 1 Gerald (Jerry) Carter 2005-02-07 10:51:11 UTC
lots of iconv changes.  Please retest against 3.0.11.  I can't reproduce this on
Linux
Comment 2 Gerald (Jerry) Carter 2005-08-24 10:19:10 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.