Bug 1711 - getpeername failed on start
getpeername failed on start
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: SWAT
3.0.6
x86 Linux
: P3 regression
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-02 09:27 UTC by David Hart
Modified: 2005-02-08 21:00 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Hart 2004-09-02 09:27:15 UTC
Sep  2 12:20:47 mail swat[30629]:   getpeername failed. Error was Socket
operation on non-socket
Sep  2 12:20:47 mail swat[30629]: [2004/09/02 12:20:47, 0]
lib/access.c:check_access(328)
Sep  2 12:20:47 mail swat[30629]: [2004/09/02 12:20:47, 0]
lib/util_sock.c:get_peer_addr(1000)
Sep  2 12:20:47 mail swat[30629]:   getpeername failed. Error was Socket
operation on non-socket
Sep  2 12:20:47 mail swat[30629]:   Denied connection from  (0.0.0.0)
Comment 1 Gerald (Jerry) Carter 2004-09-02 09:45:39 UTC
please provide much more information regarding the problem and 
how we can reproduce it.  Are you trying to launch swat from 
webmin by chance ?
Comment 2 David Hart 2004-09-02 10:28:16 UTC
(In reply to comment #1)
> please provide much more information regarding the problem and 
> how we can reproduce it.  Are you trying to launch swat from 
> webmin by chance ?

No.

I have created a properly configured file in init.d.

I have tried launching swat directly and as a service. It just hangs there
(indefinitely). I reinstalled tcp-wrappers. No change. The syslog output is the
same each time.

Running Fedora Core 2 on 2.6.8.1

I have installed from;

RPM (from fedora devel tree);
Custom compiled RPM and;
Source.

Same problem regardless of source.

I WAS using 3.06 RC2 without problems but I don't know if I made any changes to
the system since the last time I used swat was on June 28 (on 2.6.7).

I have a swat.old in /usr/sbin which is probably the RC2 SWAT. That no longer
works either.

What else would you like to know?
Comment 3 Gerald (Jerry) Carter 2005-02-08 21:00:19 UTC
swat starts from inetd/xinetd.  Not as a daemon.