Bug 1691 - smbmount not applying dirmask/fmask and ownership not translated.
smbmount not applying dirmask/fmask and ownership not translated.
Status: RESOLVED DUPLICATE of bug 999
Product: Samba 3.0
Classification: Unclassified
Component: smbclient
x86 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2004-08-31 04:56 UTC by Chris (Unrouteable address)
Modified: 2004-10-19 15:30 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Chris (Unrouteable address) 2004-08-31 04:56:26 UTC

I am experiencing some major issues with smbmount.  I have posted to the list to
see what others have to say about it, but received no response.  I assume that
this is a bug.

What used to happen with smbmount was that I would mount a share like so:

smbmount //somesever/someshare /mnt/samba -o username=myname,worgroup=wgroup

And this would mount the directory so that the server would think that all 
files transferred were owned by "myname", and all umasks, dirmasks etc. would 

This is no longer true.  It resembles more of an NFS mount:  if my UID or GID 
does not own a file or dir, I cannot access it -- period.  Even if I am 
listed as an admin user in the smb.conf.  When files are moved to that share, 
none of the create masks or directory masks get applied.  In fact, if I smbmount
as a user other than the user I am logged in as on my machine, I won't even have
rights to the files on that share (although I will have rights to the share itself).

This is a major problem, because I need administrative access to *ALL* 
home shares on the server.  Furthermore, many utility scripts run on the 
server crash because the permissions are not set right!  (not all scripts run as
root).  I used to do this with samba 2.0.7 and it worked beautifully.  I have
used 3 different versions of samba 3.x, and it no longer works.

I have tried everything listed in the man page for options (like dmask, fmask, 
krb), and it has not made a difference.

Long and short of it:

1) smbmount does not mount (or at least retain the mount) as the user 

2) The create masks, directory masks etc. are not applied to smbmounted shares 
resulting in files with bad permissions.

I am currently using 3.0.5 in an ADS environment.  My server is a domain member
of a 2003 domain and functions as the primary file and print server.

Is this broken, or is there something that can be done?  Help!


Comment 1 Björn Jacke 2004-10-19 15:30:35 UTC

*** This bug has been marked as a duplicate of 999 ***