Bug 1679 - Printing problems with Samba 3.0 under Sun Solaris
Printing problems with Samba 3.0 under Sun Solaris
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.6
Sparc Solaris
: P3 regression
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-30 03:42 UTC by Oystein Halvorsen
Modified: 2005-08-24 10:20 UTC (History)
4 users (show)

See Also:


Attachments
workaround parsing bug in print change notify code (3.54 KB, patch)
2004-09-01 08:00 UTC, Gerald (Jerry) Carter
no flags Details
test case -- disable the backgroup print queue update daemon (392 bytes, patch)
2004-09-02 07:35 UTC, Gerald (Jerry) Carter
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oystein Halvorsen 2004-08-30 03:42:27 UTC
When printing with samba 3.0.6 under solaris 9 on a sun server the jobs are 
printed and removed from the job queue as they should when finished, but the 
jobs are still shown as documents being printed on the Windows clients.  The 
samba package was successfully compiled locally with gcc version 3.3.1.  The 
install was done as an upgrade to a running version of samba.2.2.8a.  I would 
really have liked somebody to compile a binary 3.0 version that was proven to 
work properly under sun solaris.
Comment 1 Gerald (Jerry) Carter 2004-08-30 04:54:56 UTC
Are the documents showing as "Spooling" in the windows print monitor ?
Comment 2 Gerald (Jerry) Carter 2004-09-01 08:00:58 UTC
Created attachment 630 [details]
workaround parsing bug in print change notify code
Comment 3 Gerald (Jerry) Carter 2004-09-02 07:34:11 UTC
do you use netbios aliases and include files to define printers ?
If so, please try tyhis second patch as a temporary workaround.
Comment 4 Gerald (Jerry) Carter 2004-09-02 07:35:20 UTC
Created attachment 637 [details]
test case -- disable the backgroup print queue update daemon
Comment 5 Oystein Halvorsen 2004-09-15 01:21:07 UTC
In version 3.0.7 containing the proposed patch (id=630) the problem now seems 
to have been resolved.  However, the configure script gave warnings about not 
being able to compile net/if.h, netinet/ip.h and security/pam_modules.h 
(because being dependant on sys/socket.h, netinet/in.h and security/pam_appl.h 
respectively). I don't know if this has any impact, but to be sure I made a 
workaround for this by adding lines like
   #ifndef _PAM_APPL_H
   #include <security/pam_appl.h>
   #endif
in the failing include files.  This should of course be handled more 
appropriately in the samba source suite.  When compiling 3.0.6 those warnings 
were ignored by me.
Comment 6 Thomas Arendsen Hein 2004-09-17 08:42:32 UTC
(In reply to comment #5)
> In version 3.0.7 containing the proposed patch (id=630) the problem now seems 
> to have been resolved.

The problem still occurs on a debian woody (x86) machine with deb packages
version 3.0.7-1 from samba.org installed.
Comment 7 Oystein Halvorsen 2004-09-21 00:48:16 UTC
I'm afraid the problem is not fully resolved yet.  Suddenly the document lists 
again appeared to become not exhausted after jobs were printed.  Most probably 
this behaviour started when one of the printers failed for a period.  
Temporarely resolved by clearing the lists manually and then restating smbd. 
Comment 8 Gerald (Jerry) Carter 2004-10-19 10:02:09 UTC
The queue update bug is fixed by 
http://www.samba.org/~jerry/patches/post-3.0.7/printername_and_queue_update.patch
(which also fixes bug 1519).  Suggest you test 3.0.7 after applying
that patch.
Comment 9 Gerald (Jerry) Carter 2005-08-24 10:20:25 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.