Bug 1647 - Memory fault on HP-UX
Memory fault on HP-UX
Status: RESOLVED WORKSFORME
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.5
PA-RISC HP-UX
: P3 regression
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-23 01:34 UTC by Jeong-Shik Eo
Modified: 2004-08-31 07:12 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeong-Shik Eo 2004-08-23 01:34:15 UTC
I installed samba-3.0.5-11.11.depot as follow.
(HPUX B.11.11, 9000/785-C3750-HP-PA-RiSC, RAM 1GB, HD 30GB free, Swap 8388608 
block(512Byte))

1) Installed openldap-2.1.3-sd-11.00.depot
   swinstall -s /tmp/work/openldap-2.1.3-sd-11.00.depot -x \ 
allow_incompatible=true openldap

2) Installed libiconv-1.9.2-sd-11.00.depot

   swinstall -s /tmp/work/libiconv-1.9.2-sd-11.00.depot -x \ 
allow_incompatible=true openldap

3) Installed samba-3.0.5-11.11.depot

   swinstall -s /tmp/work/samba-3.0.5-11.11.depot Samba

4) Started samba

   /sbin/init.d/samba start

5) After passing 20 or 30 seconds, I could see the following message.

Pid 6312 received a SIGSEGV for stack growth failure.
Possible causes: insufficient memory or swap space,
or stack size exceeded maxssiz. 
./samba[48]: 6312 Memory fault

Pid 6313 received a SIGSEGV for stack growth failure.
Possible causes: insufficient memory or swap space,
or stack size exceeded maxssiz. 
./samba[53]: 6313 Memory fault(coredump)
#

What's wrong ? How can I do to get a successful installation of Samba ? Help 
me, please.
Comment 1 Jeong-Shik Eo 2004-08-23 01:38:36 UTC
log.nmbd
[2004/08/23 16:12:35, 0] nmbd/nmbd.c:main(664)
  Netbios nameserver version 3.0.5 started.
  Copyright Andrew Tridgell and the Samba Team 1994-2004

log.smbd
[2004/08/23 16:12:17, 1] lib/util_unistr.c:load_case_tables(63)
  creating lame upcase table
[2004/08/23 16:12:17, 1] lib/util_unistr.c:load_case_tables(78)
  creating lame lowcase table
[2004/08/23 16:12:17, 0] smbd/server.c:main(757)
  smbd version 3.0.5 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2004
Comment 2 Gerald (Jerry) Carter 2004-08-31 07:12:47 UTC
This looks like either (a) a problem with the packages
or (b) an HP-UX tuniung issue.  My suggestion is to post 
for help from the samba mailing list.  We're not going to 
be able to provide any help on this one unless you can 
help point us to a bug in the Samba source code.

Sorry wish I had better news.