Bug 1645 - smbcacls (samba 3.0.6) segmentation fault in redhat 7.x
smbcacls (samba 3.0.6) segmentation fault in redhat 7.x
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.6
x86 Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-22 07:26 UTC by Stefan Woerner
Modified: 2005-08-24 10:16 UTC (History)
0 users

See Also:


Attachments
strace output of smbcacls (11.04 KB, text/plain)
2004-08-23 01:37 UTC, Stefan Woerner
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Woerner 2004-08-22 07:26:13 UTC
I rebuilt the samba 3.0.6 sources on a Redhat 7.2 (kernel 2.4.20-27.7smp) like I
did with the samba 3.0.5 sources, since there a no precompiled 3.0.x rpms for
redhat 7.3 any more.
In 3.0.5 smbcacls worked. Now, I get a segmentation fault, even starting
smbcacls without any options.
On another machine with fedora core 2 smbcacls (version 3.0.6) works without errors.
Comment 1 Stefan Woerner 2004-08-23 01:37:35 UTC
Created attachment 611 [details]
strace output of smbcacls

Here I provide a strace output of smbcacls.
Comment 2 Stefan Woerner 2004-11-09 05:25:51 UTC
Problem is solved by samba-3.0.8.
Comment 3 Gerald (Jerry) Carter 2005-08-24 10:16:49 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.