Bug 164 - RH8.0 error during rpm upgrade from samba-2.2.7
RH8.0 error during rpm upgrade from samba-2.2.7
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: Packaging
3.0.0preX
All Linux
: P2 major
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-14 11:22 UTC by Gerry Reno
Modified: 2005-11-14 09:31 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry Reno 2003-06-14 11:22:31 UTC
# rpm -Uvh samba-3.0.0beta1-1.i386.rpm
warning: samba-3.0.0beta1-1.i386.rpm: V3 DSA signature: NOKEY, key ID 2f87af6f
Preparing...                ########################################### [100%]
   1:samba                  warning: /etc/samba/smb.conf created as
/etc/samba/smb.conf.rpmnew
########################################### [100%]
Looking for old /etc/smb.conf...
Looking for old /etc/smbusers...
Looking for old /etc/lmhosts...
Looking for old /etc/MACHINE.SID...
Looking for old /etc/smbpasswd...
Moving tdb files in /var/lock/samba/*.tdb to /var/cache/samba/*.tdb
Installing stack version of /etc/pam.d/samba...
error: %postun(samba-2.2.7-2) scriptlet failed, exit status 1
Comment 1 Gerry Reno 2003-06-14 11:24:51 UTC
Can I recover from the above error?

Comment 2 Gerry Reno 2003-06-14 11:30:41 UTC
also, not seeing any mail from this bug.
Comment 3 Gerry Reno 2003-06-14 11:42:34 UTC
ignore the mail comment, they just came in all at once.
Comment 4 Gerry Reno 2003-06-14 12:16:31 UTC
even with the error, rpm is reporting: 
 # rpm -q samba
samba-3.0.0beta1-1

starting and stopping smb works.
I can read/write smbmounted filesystems.

So, is this error significant?

Comment 5 Gerald (Jerry) Carter 2003-06-23 09:43:23 UTC
was the 2.2.7 RPM from samba.org?  or from RH? The error 
reported is from the 2.2.7 uninstall portion (part of that 
RPM not the 3.0 RPM if I'm reading it correctly).
Comment 6 Gerry Reno 2003-06-23 10:43:46 UTC
Samba 2.2.7 was installed from RH installation cd.
Comment 7 Gerald (Jerry) Carter 2003-06-23 11:36:24 UTC
I don;t think this is our bug then.  The uninstall probably failed 
because the 3.0 RPM moved some files around).  Probably nothing to 
worry about.  

Marking as invalid since it was RH's rpm that generated the error.
Comment 8 Gerry Reno 2003-06-23 12:05:36 UTC
Well, if the 3.0 version moves files around prior to 2.2.7 doing its uninstall
then I see that as a samba.org problem and not a RedHat problem.  

At the very least I think the possibility of this error message should be
documented for RedHat users - maybe in a installation guide or readme.
Comment 9 Gerald (Jerry) Carter 2005-02-07 08:39:29 UTC
originally reported against 3.0.0beta1.  CLeaning out 
non-production release versions.
Comment 10 Gerald (Jerry) Carter 2005-11-14 09:31:32 UTC
database cleanup