Bug 1635 - ksoftirq at 100% CPU utilization after restart of nmbd
ksoftirq at 100% CPU utilization after restart of nmbd
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: nmbd
3.0.5
s390 Linux
: P3 major
: none
Assigned To: Jim McDonough
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-19 23:23 UTC by Frank Becker
Modified: 2004-08-23 11:03 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Becker 2004-08-19 23:23:04 UTC
After restarting nmbd (with rcnmb restart) ksoftirq leads up to 100% cpu 
utilization. This problem is reproducable on several s390 systems with samba3-
3.0.0, samba3-3.0.2 and samba3-3.0.5.

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
    7 root      39  19     0    0    0 R 99.9  0.0  18:49.12 ksoftirqd_CPU0

The only way i know to solve the problem is reboot.

Most time the problem is reproducable after one restart, sometimes the problem 
exists after reboot and sometimes it is possible to restart nmbd 5 times 
without having a problem.

Test-Environment:
System: SuSE SLES-8 (S/390)
        VERSION = 8.1 
        3 CPU
Kernel: Linux deidshostz0012 2.4.21-83-default #1 SMP Fri Oct 31 00:38:02 UTC 
2003 s390 unknown
Samba: samba3-client-3.0.5-8.1
       samba3-winbind-3.0.5-8.1
       samba3-3.0.5-8.1
       samba3-doc-3.0.5-8.1
       libsmbclient-3.0.5-8.1
       libsmbclient-devel-3.0.5-8.1
smb.conf:
[global]
idmap uid = 10000-30000
idmap gid = 10000-30000
case sensitive = yes

workgroup = karlsruher
netbios name = DEIDSHOSTZ0012
security = ADS
realm = KARLSRUHER.DE
password server = *
encrypt passwords = yes
name resolve order = wins bcast
server string = Samba Fileserver
wins server = 10.1.2.19 10.13.3.26
unix extensions = Yes
map archive = no
map hidden = no
map system =no

[u123112]
path = /samba/user/u123112
public = yes
browseable = yes
read only = no
create mask = 0664
directory mask = 0775

Network:
dummy0    Link encap:Ethernet  HWaddr 00:00:00:00:00:00
          inet addr:10.2.102.21  Bcast:10.2.255.255  Mask:255.255.255.252
          inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1001 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:90158 (88.0 Kb)

eth0      Link encap:Ethernet  HWaddr 00:09:6B:F6:21:59
          inet addr:10.2.2.32  Bcast:10.2.2.255  Mask:255.255.255.0
          inet6 addr: fe80::9:6b00:3af6:2159/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:19578 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1007 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:9309110 (8.8 Mb)  TX bytes:151815 (148.2 Kb)
          Interrupt:5

eth1      Link encap:Ethernet  HWaddr 00:09:6B:F6:1E:F5
          inet addr:10.2.4.32  Bcast:10.2.4.255  Mask:255.255.255.0
          inet6 addr: fe80::9:6b00:3af6:1ef5/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10743 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3149 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:1230176 (1.1 Mb)  TX bytes:369839 (361.1 Kb)
          Interrupt:8

hsi1      Link encap:Ethernet  HWaddr 00:00:00:00:00:00
          inet addr:10.200.10.212  Mask:255.255.255.0
          inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
          UP RUNNING NOARP MULTICAST  MTU:16384  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:145 errors:133 dropped:133 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:0 (0.0 b)  TX bytes:23682 (23.1 Kb)
          Interrupt:14

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1314 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1314 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:151986 (148.4 Kb)  TX bytes:151986 (148.4 Kb)

tr0       Link encap:16/4 Mbps Token Ring  HWaddr 40:00:7F:FF:00:06
          inet addr:10.1.1.212  Bcast:10.1.255.255  Mask:255.255.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:11748 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6362 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:1728680 (1.6 Mb)  TX bytes:2244198 (2.1 Mb)
          Interrupt:11

filesystem:
/dev/dasdk1 on / type reiserfs (rw)
proc on /proc type proc (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/klv_vg/home_lv on /home type reiserfs (rw)
/dev/klv_vg/opt_lv on /opt type reiserfs (rw)
/dev/klv_vg/tmp_lv on /tmp type reiserfs (rw)
/dev/klv_vg/usr_lv on /usr type reiserfs (rw)
/dev/klv_vg/var_lv on /var type reiserfs (rw)
/dev/samba_vg/samba_project_lv on /samba/project type reiserfs 
(rw,acl,usrquota,grpquota)
/dev/samba_vg/samba_user_lv on /samba/user type reiserfs 
(rw,acl,usrquota,grpquota)
/dev/samba_vg/samba_buero_lv on /samba/buero type reiserfs 
(rw,acl,usrquota,grpquota)
shmfs on /dev/shm type shm (rw)
The problem is reproducable with ext3 filesystem, too.
Comment 1 Gerald (Jerry) Carter 2004-08-20 15:57:12 UTC
s390 ?  Jim ?
Comment 2 Jim McDonough 2004-08-20 16:21:52 UTC
I think this should be reported to SuSE.  Samba shouldn't be able to cause this.
 Adding Lars to cc:
Comment 3 Lars Müller 2004-08-23 08:27:29 UTC
As Jim suggested: Please contact the SuSE support department and provide as
detailed as possible information about the microcode and patch level of your
S390 system.

I suggest to close this bug as from my point of view this is a hardware or
kernel driver problem only triggered by Samba.
Comment 4 Gerald (Jerry) Carter 2004-08-23 11:03:08 UTC
closing this bug since it will be escalated through SuSE.