Bug 163 - smbd receives sig11 when trying to login on a windows 2k machine
smbd receives sig11 when trying to login on a windows 2k machine
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
3.0.0preX
All Linux
: P4 normal
: none
Assigned To: Simo Sorce
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-14 07:02 UTC by Lukas Beeler
Modified: 2005-11-14 09:26 UTC (History)
0 users

See Also:


Attachments
a gdb 'where' and disass of the function before the sig11 (62.64 KB, text/plain)
2003-06-14 07:06 UTC, Lukas Beeler
no flags Details
The logfile that samba produced when it crashed. Created with -D10 (43.20 KB, text/plain)
2003-06-14 07:07 UTC, Lukas Beeler
no flags Details
The smb.conf i used when samba crashed (721 bytes, text/plain)
2003-06-14 07:08 UTC, Lukas Beeler
no flags Details
All .tdb files, tared shortly after the crash (2.86 KB, application/octet-stream)
2003-06-14 07:10 UTC, Lukas Beeler
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Beeler 2003-06-14 07:02:08 UTC
I tried to setup a testing enviroment for samba, with one win2k machine as
client, and a linux box as PDC. When i try to login with the user 'gb', samba
receives a sig11, and dumps a core file. This bug is easely to reproduce. See
attached files for more details (configuration, logs, gdb output, tdb files).
Comment 1 Lukas Beeler 2003-06-14 07:06:27 UTC
Created attachment 25 [details]
a gdb 'where' and disass of the function before the sig11
Comment 2 Lukas Beeler 2003-06-14 07:07:50 UTC
Created attachment 26 [details]
The logfile that samba produced when it crashed. Created with -D10
Comment 3 Lukas Beeler 2003-06-14 07:08:22 UTC
Created attachment 27 [details]
The smb.conf i used when samba crashed
Comment 4 Lukas Beeler 2003-06-14 07:10:49 UTC
Created attachment 28 [details]
All .tdb files, tared shortly after the crash

secrets.tdb has been included, because it does not contain important
information. It is just a test setup, and dummy passwords have been used.
Comment 5 Gerald (Jerry) Carter 2003-06-23 09:41:48 UTC
please review this report and marked as fixed 
if already taken care of.  Thanks.
Comment 6 Simo Sorce 2003-06-23 14:07:49 UTC
Can you remove the "idmap backend = tdb" parameter and retry?

Simo.
Comment 7 Lukas Beeler 2003-06-23 14:52:32 UTC
It reports this messages then. Which looks wrong too. However, it doesnt crash
anymore.

[2003/06/23 21:33:15, 1] sam/idmap_tdb.c:db_idmap_init(319)
  idmap uid range missing or invalid
  idmap will be unable to map foreign SIDs
[2003/06/23 21:33:15, 1] sam/idmap_tdb.c:db_idmap_init(331)
  idmap gid range missing or invalid
  idmap will be unable to map foreign SIDs
Comment 8 Simo Sorce 2003-06-23 15:54:56 UTC
Ok then I think the bug is closed, I'll take care of avoiding a module to be
called to times.
About ranges, if you're not using winbind then they may be ok, depending on your
taste.
Comment 9 Gerald (Jerry) Carter 2005-02-07 08:39:08 UTC
originally reported against 3.0.0beta1.  CLeaning out 
non-production release versions.
Comment 10 Gerald (Jerry) Carter 2005-08-24 10:22:48 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 11 Gerald (Jerry) Carter 2005-11-14 09:26:45 UTC
database cleanup