Bug 1586 - Constant failure with the [homes] share.
Constant failure with the [homes] share.
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.5
All Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-04 20:28 UTC by Robert Edstrom
Modified: 2005-08-24 10:17 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Edstrom 2004-08-04 20:28:42 UTC
I recently upgraded a samba 2.2.8a test PDC to samba 3.0.5 using the samba 
source .  Everything went rather smoothly.  I have been playing with earlier 
versions of the 3.x versions.  I think the last version I played with was .0.3.

Anyway, I am running it 3.0.5 on a redhat 8 box using a 2.4.20 kernel with the 
ACL patch from acl.bestbits.at.  Samba gets it's authentication from LDAP, 
openldap 2.1.22, running on the same box.

The problem is that after the upgrade, I noticed that the [homes] share failed 
constantly.  I get an error saying that the share is not accessible.  I need to 
check with my system administrator.  On the server side, I get the following 
log: "[2004/08/04 14:58:53, 2] smbd/service.c:make_connection(723)
  [homes] share not available for this user because it was not found or created 
at session setup time."

I looked at bugzilla and noticed a similar bug: 
https://bugzilla.samba.org/show_bug.cgi?id=130.  This is exactly what I am 
seeing here.

My [homes] share is configured like this:

[Homes]
	comment			= Home Directory for %U
	path			= %H
	valid users		= %S
	read only		= No
	create mask		= 0660
	security mask		= 0660
	directory mask		= 2770
	directory security mask	= 2770
	browseable		= No
	volume			= "Home Directory"
	follow symlinks		= No


Global options include:

------------------------

	map to guest		= never

	ldap admin dn		= ..........
	ldap port		= 389
	ldap server		= localhost
	ldap ssl		= no
	ldap suffix		= ..........

	idmap backend		= ldapsam_compat:ldap://localhost
	passdb backend		= ldapsam_compat:ldap://localhost


	ldap user suffix	= ou=People
	ldap group suffix	= ou=Group
	ldap machine suffix	= ou=Workstations,ou=People

------------------------

The ldap admin dn has read and write access to the entire directory.  Using 
pdbedit -Lv I can view all user and computer account information.  What am I 
doing wrong?  Is this a bug or something that I may have missed.  This occured 
with windows xp clients.  I build a couple of 2k boxes to see what happens.  I 
haven't seen this behavior on 98se clients.

Thanks in advance.
Comment 1 Robert Edstrom 2004-08-07 10:50:08 UTC
Hi, I also noticed that this behavior occurs with windows 2000 clients also.  I 
have not noticed this with a windows 98 se machine.
Comment 2 Gerald (Jerry) Carter 2004-08-09 11:04:29 UTC
please send me a level 10 samba debug log.
Comment 3 Robert Edstrom 2004-08-09 22:56:18 UTC
I uninstalled 3.0.5, then backed down to 3.0.4.  The behavior was still there 
so I backed down to 2.2.10.  I'll up it again to 3.0.5 and test.  Hopefully 
this error will show up.

Do you see anything wrong with the following configure options that I have set?

--prefix=/usr \
--bindir=/usr/bin \
--sbindir=/usr/sbin \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/share/man \
--with-fhs \
--with-privatedir=/etc/samba/private \
--with-lockdir=/var/lock/samba \
--with-piddir=/var/run \
--with-swatdir=/usr/share/samba/swat \
--with-configdir=/etc/samba \
--with-logfilebase=/var/log/samba \
--with-ldap \
--without-ads \
--with-automount \
--with-smbmount \
--with-ldapsam \
--with-quotas \
--with-sys-quotas \
--with-libsmbclient \
--with-acl-support \
--without-winbind

I also noticed that the printer drivers broke everytime that I rebooted the 
machine.  It is as if I never loaded the drivers onto the server in the first 
place.
Comment 4 Robert Edstrom 2004-08-10 21:20:08 UTC
------------------------------------------
[2004/08/10 01:16:27, 5] lib/util_seaccess.c:se_access_check(309)
  se_access_check: access (1) granted.
[2004/08/10 01:16:27, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (99, 99) - sec_ctx_stack_ndx = 0
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_nt_user_token(491)
  NT user token of user S-1-5-21-2652362219-1738345525-1156227534-501
  contains 6 SIDs
  SID[  0]: S-1-5-21-2652362219-1738345525-1156227534-501
  SID[  1]: S-1-5-21-2652362219-1738345525-1156227534-514
  SID[  2]: S-1-1-0
  SID[  3]: S-1-5-2
  SID[  4]: S-1-5-32-546
  SID[  5]: S-1-5-21-2652362219-1738345525-1156227534-1199
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_unix_user_token(505)
  UNIX token of user 99
  Primary group is 99 and contains 1 supplementary groups
  Group[  0]: 99
[2004/08/10 01:16:27, 5] smbd/uid.c:change_to_user(267)
  change_to_user uid=(99,99) gid=(0,99)
[2004/08/10 01:16:27, 3] smbd/service.c:make_connection_snum(619)
  sunstar (192.168.0.11) connect to service ipc$ initially as user nobody 
(uid=99, gid=99) (pid 12434)
[2004/08/10 01:16:27, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_nt_user_token(486)
  NT user token: (NULL)
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_unix_user_token(505)
  UNIX token of user 0
  Primary group is 0 and contains 0 supplementary groups
[2004/08/10 01:16:27, 5] smbd/uid.c:change_to_root_user(282)
  change_to_root_user: now uid=(0,0) gid=(0,0)
[2004/08/10 01:16:27, 3] smbd/reply.c:reply_tcon_and_X(429)
  tconX service=IPC$ 
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(456)
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(466)
  size=48
  smb_com=0x75
  smb_rcls=0
  smb_reh=0
  smb_err=0
  smb_flg=136
  smb_flg2=51201
  smb_tid=4
  smb_pid=65279
  smb_uid=108
  smb_mid=34241
  smt_wct=3
  smb_vwv[ 0]=  255 (0xFF)
  smb_vwv[ 1]=    0 (0x0)
  smb_vwv[ 2]=    1 (0x1)
  smb_bcc=7
[2004/08/10 01:16:27, 10] lib/util.c:dump_data(1864)
  [000] 49 50 43 00 00 00 00                              IPC.... 
[2004/08/10 01:16:27, 6] lib/util_sock.c:write_socket(432)
  write_socket(25,52)
[2004/08/10 01:16:27, 6] lib/util_sock.c:write_socket(435)
  write_socket(25,52) wrote 52
[2004/08/10 01:16:27, 10] lib/util_sock.c:read_smb_length_return_keepalive(488)
  got smb length of 78
[2004/08/10 01:16:27, 6] smbd/process.c:process_smb(889)
  got message type 0x0 of len 0x4e
[2004/08/10 01:16:27, 3] smbd/process.c:process_smb(890)
  Transaction 543 of length 82
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(456)
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(466)
  size=78
  smb_com=0x75
  smb_rcls=0
  smb_reh=0
  smb_err=0
  smb_flg=24
  smb_flg2=51207
  smb_tid=0
  smb_pid=65279
  smb_uid=105
  smb_mid=34305
  smt_wct=4
  smb_vwv[ 0]=  255 (0xFF)
  smb_vwv[ 1]=   78 (0x4E)
  smb_vwv[ 2]=    8 (0x8)
  smb_vwv[ 3]=    1 (0x1)
  smb_bcc=35
[2004/08/10 01:16:27, 10] lib/util.c:dump_data(1864)
  [000] 00 5C 00 5C 00 4E 00 41  00 59 00 52 00 55 00 5C  .\.\.N.A .Y.R.U.\
  [010] 00 48 00 4F 00 4D 00 45  00 53 00 00 00 3F 3F 3F  .H.O.M.E .S...???
  [020] 3F 3F 00                                          ??. 
[2004/08/10 01:16:27, 3] smbd/process.c:switch_message(685)
  switch message SMBtconX (pid 12434)
[2004/08/10 01:16:27, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_nt_user_token(486)
  NT user token: (NULL)
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_unix_user_token(505)
  UNIX token of user 0
  Primary group is 0 and contains 0 supplementary groups
[2004/08/10 01:16:27, 5] smbd/uid.c:change_to_root_user(282)
  change_to_root_user: now uid=(0,0) gid=(0,0)
[2004/08/10 01:16:27, 4] smbd/reply.c:reply_tcon_and_X(381)
  Client requested device type [?????] for share [HOMES]
[2004/08/10 01:16:27, 2] smbd/service.c:make_connection(723)
  [homes] share not available for this user because it was not found or created 
at session setup time
[2004/08/10 01:16:27, 3] smbd/error.c:error_packet(118)
  error packet at smbd/reply.c(389) cmd=117 (SMBtconX) 
NT_STATUS_BAD_NETWORK_NAME
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(456)
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(466)
  size=35
  smb_com=0x75
  smb_rcls=204
  smb_reh=0
  smb_err=49152
  smb_flg=136
  smb_flg2=51201
  smb_tid=0
  smb_pid=65279
  smb_uid=105
  smb_mid=34305
  smt_wct=0
  smb_bcc=0
[2004/08/10 01:16:27, 6] lib/util_sock.c:write_socket(432)
  write_socket(25,39)
[2004/08/10 01:16:27, 6] lib/util_sock.c:write_socket(435)
  write_socket(25,39) wrote 39
[2004/08/10 01:16:27, 10] lib/util_sock.c:read_smb_length_return_keepalive(488)
  got smb length of 78
[2004/08/10 01:16:27, 6] smbd/process.c:process_smb(889)
  got message type 0x0 of len 0x4e
[2004/08/10 01:16:27, 3] smbd/process.c:process_smb(890)
  Transaction 544 of length 82
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(456)
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(466)
  size=78
  smb_com=0x75
  smb_rcls=0
  smb_reh=0
  smb_err=0
  smb_flg=24
  smb_flg2=51207
  smb_tid=0
  smb_pid=65279
  smb_uid=105
  smb_mid=34369
  smt_wct=4
  smb_vwv[ 0]=  255 (0xFF)
  smb_vwv[ 1]=   78 (0x4E)
  smb_vwv[ 2]=    8 (0x8)
  smb_vwv[ 3]=    1 (0x1)
  smb_bcc=35
[2004/08/10 01:16:27, 10] lib/util.c:dump_data(1864)
  [000] 00 5C 00 5C 00 4E 00 41  00 59 00 52 00 55 00 5C  .\.\.N.A .Y.R.U.\
  [010] 00 48 00 4F 00 4D 00 45  00 53 00 00 00 3F 3F 3F  .H.O.M.E .S...???
  [020] 3F 3F 00                                          ??. 
[2004/08/10 01:16:27, 3] smbd/process.c:switch_message(685)
  switch message SMBtconX (pid 12434)
[2004/08/10 01:16:27, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_nt_user_token(486)
  NT user token: (NULL)
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_unix_user_token(505)
  UNIX token of user 0
  Primary group is 0 and contains 0 supplementary groups
[2004/08/10 01:16:27, 5] smbd/uid.c:change_to_root_user(282)
  change_to_root_user: now uid=(0,0) gid=(0,0)
[2004/08/10 01:16:27, 4] smbd/reply.c:reply_tcon_and_X(381)
  Client requested device type [?????] for share [HOMES]
[2004/08/10 01:16:27, 2] smbd/service.c:make_connection(723)
  [homes] share not available for this user because it was not found or created 
at session setup time
[2004/08/10 01:16:27, 3] smbd/error.c:error_packet(118)
  error packet at smbd/reply.c(389) cmd=117 (SMBtconX) 
NT_STATUS_BAD_NETWORK_NAME
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(456)
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(466)
  size=35
  smb_com=0x75
  smb_rcls=204
  smb_reh=0
  smb_err=49152
  smb_flg=136
  smb_flg2=51201
  smb_tid=0
  smb_pid=65279
  smb_uid=105
  smb_mid=34369
  smt_wct=0
  smb_bcc=0
[2004/08/10 01:16:27, 6] lib/util_sock.c:write_socket(432)
  write_socket(25,39)
[2004/08/10 01:16:27, 6] lib/util_sock.c:write_socket(435)
  write_socket(25,39) wrote 39
[2004/08/10 01:16:27, 10] lib/util_sock.c:read_smb_length_return_keepalive(488)
  got smb length of 35
[2004/08/10 01:16:27, 6] smbd/process.c:process_smb(889)
  got message type 0x0 of len 0x23
[2004/08/10 01:16:27, 3] smbd/process.c:process_smb(890)
  Transaction 545 of length 39
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(456)
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(466)
  size=35
  smb_com=0x71
  smb_rcls=0
  smb_reh=0
  smb_err=0
  smb_flg=24
  smb_flg2=51207
  smb_tid=2
  smb_pid=65279
  smb_uid=105
  smb_mid=34433
  smt_wct=0
  smb_bcc=0
[2004/08/10 01:16:27, 3] smbd/process.c:switch_message(685)
  switch message SMBtdis (pid 12434)
[2004/08/10 01:16:27, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_nt_user_token(486)
  NT user token: (NULL)
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_unix_user_token(505)
  UNIX token of user 0
  Primary group is 0 and contains 0 supplementary groups
[2004/08/10 01:16:27, 5] smbd/uid.c:change_to_root_user(282)
  change_to_root_user: now uid=(0,0) gid=(0,0)
[2004/08/10 01:16:27, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_nt_user_token(486)
  NT user token: (NULL)
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_unix_user_token(505)
  UNIX token of user 0
  Primary group is 0 and contains 0 supplementary groups
[2004/08/10 01:16:27, 5] smbd/uid.c:change_to_root_user(282)
  change_to_root_user: now uid=(0,0) gid=(0,0)
[2004/08/10 01:16:27, 3] smbd/service.c:close_cnum(801)
  sunstar (192.168.0.11) closed connection to service ipc$
[2004/08/10 01:16:27, 3] smbd/connection.c:yield_connection(69)
  Yielding connection to ipc$
[2004/08/10 01:16:27, 4] smbd/vfs.c:vfs_ChDir(654)
  vfs_ChDir to /
[2004/08/10 01:16:27, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_nt_user_token(486)
  NT user token: (NULL)
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_unix_user_token(505)
  UNIX token of user 0
  Primary group is 0 and contains 0 supplementary groups
[2004/08/10 01:16:27, 5] smbd/uid.c:change_to_root_user(282)
  change_to_root_user: now uid=(0,0) gid=(0,0)
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(456)
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(466)
  size=35
  smb_com=0x71
  smb_rcls=0
  smb_reh=0
  smb_err=0
  smb_flg=136
  smb_flg2=51201
  smb_tid=2
  smb_pid=65279
  smb_uid=105
  smb_mid=34433
  smt_wct=0
  smb_bcc=0
[2004/08/10 01:16:27, 6] lib/util_sock.c:write_socket(432)
  write_socket(25,39)
[2004/08/10 01:16:27, 6] lib/util_sock.c:write_socket(435)
  write_socket(25,39) wrote 39
[2004/08/10 01:16:27, 10] lib/util_sock.c:read_smb_length_return_keepalive(488)
  got smb length of 35
[2004/08/10 01:16:27, 6] smbd/process.c:process_smb(889)
  got message type 0x0 of len 0x23
[2004/08/10 01:16:27, 3] smbd/process.c:process_smb(890)
  Transaction 546 of length 39
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(456)
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(466)
  size=35
  smb_com=0x71
  smb_rcls=0
  smb_reh=0
  smb_err=0
  smb_flg=24
  smb_flg2=51207
  smb_tid=4
  smb_pid=65279
  smb_uid=108
  smb_mid=34497
  smt_wct=0
  smb_bcc=0
[2004/08/10 01:16:27, 3] smbd/process.c:switch_message(685)
  switch message SMBtdis (pid 12434)
[2004/08/10 01:16:27, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_nt_user_token(486)
  NT user token: (NULL)
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_unix_user_token(505)
  UNIX token of user 0
  Primary group is 0 and contains 0 supplementary groups
[2004/08/10 01:16:27, 5] smbd/uid.c:change_to_root_user(282)
  change_to_root_user: now uid=(0,0) gid=(0,0)
[2004/08/10 01:16:27, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_nt_user_token(486)
  NT user token: (NULL)
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_unix_user_token(505)
  UNIX token of user 0
  Primary group is 0 and contains 0 supplementary groups
[2004/08/10 01:16:27, 5] smbd/uid.c:change_to_root_user(282)
  change_to_root_user: now uid=(0,0) gid=(0,0)
[2004/08/10 01:16:27, 3] smbd/service.c:close_cnum(801)
  sunstar (192.168.0.11) closed connection to service ipc$
[2004/08/10 01:16:27, 3] smbd/connection.c:yield_connection(69)
  Yielding connection to ipc$
[2004/08/10 01:16:27, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_nt_user_token(486)
  NT user token: (NULL)
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_unix_user_token(505)
  UNIX token of user 0
  Primary group is 0 and contains 0 supplementary groups
[2004/08/10 01:16:27, 5] smbd/uid.c:change_to_root_user(282)
  change_to_root_user: now uid=(0,0) gid=(0,0)
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(456)
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(466)
  size=35
  smb_com=0x71
  smb_rcls=0
  smb_reh=0
  smb_err=0
  smb_flg=136
  smb_flg2=51201
  smb_tid=4
  smb_pid=65279
  smb_uid=108
  smb_mid=34497
  smt_wct=0
  smb_bcc=0
[2004/08/10 01:16:27, 6] lib/util_sock.c:write_socket(432)
  write_socket(25,39)
[2004/08/10 01:16:27, 6] lib/util_sock.c:write_socket(435)
  write_socket(25,39) wrote 39
[2004/08/10 01:16:27, 10] lib/util_sock.c:read_smb_length_return_keepalive(488)
  got smb length of 39
[2004/08/10 01:16:27, 6] smbd/process.c:process_smb(889)
  got message type 0x0 of len 0x27
[2004/08/10 01:16:27, 3] smbd/process.c:process_smb(890)
  Transaction 547 of length 43
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(456)
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(466)
  size=39
  smb_com=0x74
  smb_rcls=0
  smb_reh=0
  smb_err=0
  smb_flg=24
  smb_flg2=51207
  smb_tid=0
  smb_pid=65279
  smb_uid=108
  smb_mid=34561
  smt_wct=2
  smb_vwv[ 0]=  255 (0xFF)
  smb_vwv[ 1]=    0 (0x0)
  smb_bcc=0
[2004/08/10 01:16:27, 3] smbd/process.c:switch_message(685)
  switch message SMBulogoffX (pid 12434)
[2004/08/10 01:16:27, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_nt_user_token(486)
  NT user token: (NULL)
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_unix_user_token(505)
  UNIX token of user 0
  Primary group is 0 and contains 0 supplementary groups
[2004/08/10 01:16:27, 5] smbd/uid.c:change_to_root_user(282)
  change_to_root_user: now uid=(0,0) gid=(0,0)
[2004/08/10 01:16:27, 5] auth/auth_util.c:free_server_info(1324)
  attempting to free (and zero) a server_info structure
[2004/08/10 01:16:27, 3] smbd/reply.c:reply_ulogoffX(1207)
  ulogoffX vuid=108
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(456)
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(466)
  size=39
  smb_com=0x74
  smb_rcls=0
  smb_reh=0
  smb_err=0
  smb_flg=136
  smb_flg2=51201
  smb_tid=0
  smb_pid=65279
  smb_uid=108
  smb_mid=34561
  smt_wct=2
  smb_vwv[ 0]=  255 (0xFF)
  smb_vwv[ 1]=    0 (0x0)
  smb_bcc=0
[2004/08/10 01:16:27, 6] lib/util_sock.c:write_socket(432)
  write_socket(25,43)
[2004/08/10 01:16:27, 6] lib/util_sock.c:write_socket(435)
  write_socket(25,43) wrote 43
[2004/08/10 01:16:27, 10] lib/util_sock.c:read_smb_length_return_keepalive(488)
  got smb length of 78
[2004/08/10 01:16:27, 6] smbd/process.c:process_smb(889)
  got message type 0x0 of len 0x4e
[2004/08/10 01:16:27, 3] smbd/process.c:process_smb(890)
  Transaction 548 of length 82
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(456)
[2004/08/10 01:16:27, 5] lib/util.c:show_msg(466)
  size=78
  smb_com=0x75
  smb_rcls=0
  smb_reh=0
  smb_err=0
  smb_flg=24
  smb_flg2=51207
  smb_tid=0
  smb_pid=65279
  smb_uid=105
  smb_mid=34625
  smt_wct=4
  smb_vwv[ 0]=  255 (0xFF)
  smb_vwv[ 1]=   78 (0x4E)
  smb_vwv[ 2]=    8 (0x8)
  smb_vwv[ 3]=    1 (0x1)
  smb_bcc=35
[2004/08/10 01:16:27, 10] lib/util.c:dump_data(1864)
  [000] 00 5C 00 5C 00 4E 00 41  00 59 00 52 00 55 00 5C  .\.\.N.A .Y.R.U.\
  [010] 00 48 00 4F 00 4D 00 45  00 53 00 00 00 3F 3F 3F  .H.O.M.E .S...???
  [020] 3F 3F 00                                          ??. 
[2004/08/10 01:16:27, 3] smbd/process.c:switch_message(685)
  switch message SMBtconX (pid 12434)
[2004/08/10 01:16:27, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_nt_user_token(486)
  NT user token: (NULL)
[2004/08/10 01:16:27, 5] auth/auth_util.c:debug_unix_user_token(505)
  UNIX token of user 0
  Primary group is 0 and contains 0 supplementary groups
[2004/08/10 01:16:27, 5] smbd/uid.c:change_to_root_user(282)
  change_to_root_user: now uid=(0,0) gid=(0,0)
[2004/08/10 01:16:27, 4] smbd/reply.c:reply_tcon_and_X(381)
  Client requested device type [?????] for share [HOMES]
[2004/08/10 01:16:27, 2] smbd/service.c:make_connection(723)
  [homes] share not available for this user because it was not found or created 
at session setup time

------------------------------------------

This is an older level 10 debug log from before I removed 3.0.5.  The strange 
thing is that this machine is a domain controller and it maps 2 drives before 
it attempts to map the homes share.  The first 2 drives get mapped, but homes 
fails.  The log shows as if the user nobody is trying to connect to the server.

Another things is that after failing a few times, it seems to magically work 
after a while.  But if I log off the workstation and log back in a few times, 
it fails again after working a few more times.
Comment 5 Robert Edstrom 2004-08-10 21:23:27 UTC
Has anyone else seen something like this with samba 3.0.x using an LDAP backend 
or any backend?  Could it be some kind of misconfiguration on my end?
Comment 6 Kristyan Osborne 2004-08-12 02:53:30 UTC
I have noticed this behaviour in samba 3.0.5 using an ldap backend. I have 
found if I change sambaHomePath from \\mc095\homes to \\mc095\username (where 
username is a name i.e. kris), I never get the problem when the sambaHomePath 
is configured this way.

I have set a few users this way, as I'm hoping this bug will be fixed soon 
otherwise it will mean having to chage about 1200 users sambaHomePath.

I have included a level 10 debug. Hope this helps..


[2004/08/12 09:37:40, 5] lib/util.c:show_msg(456)
[2004/08/12 09:37:40, 5] lib/util.c:show_msg(466)
  size=78
  smb_com=0x75
  smb_rcls=0
  smb_reh=0
  smb_err=0
  smb_flg=24
  smb_flg2=51207
  smb_tid=0
  smb_pid=65279
  smb_uid=129
  smb_mid=42817
  smt_wct=4
  smb_vwv[ 0]=  255 (0xFF)
  smb_vwv[ 1]=   78 (0x4E)
  smb_vwv[ 2]=    8 (0x8)
  smb_vwv[ 3]=    1 (0x1)
  smb_bcc=35
[2004/08/12 09:37:40, 10] lib/util.c:dump_data(1864)
  [000] 00 5C 00 5C 00 4D 00 43  00 30 00 39 00 35 00 5C  .\.\.M.C .0.9.5.\
  [010] 00 48 00 4F 00 4D 00 45  00 53 00 00 00 3F 3F 3F  .H.O.M.E .S...???
  [020] 3F 3F 00                                          ??. 
[2004/08/12 09:37:40, 3] smbd/process.c:switch_message(685)
  switch message SMBtconX (pid 24674)
[2004/08/12 09:37:40, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2004/08/12 09:37:40, 5] auth/auth_util.c:debug_nt_user_token(486)
  NT user token: (NULL)
[2004/08/12 09:37:40, 5] auth/auth_util.c:debug_unix_user_token(505)
  UNIX token of user 0
  Primary group is 0 and contains 0 supplementary groups
[2004/08/12 09:37:40, 5] smbd/uid.c:change_to_root_user(282)
  change_to_root_user: now uid=(0,0) gid=(0,0)
[2004/08/12 09:37:40, 4] smbd/reply.c:reply_tcon_and_X(381)
  Client requested device type [?????] for share [HOMES]
[2004/08/12 09:37:40, 2] smbd/service.c:make_connection(723)
  [homes] share not available for this user because it was not found or created 
at session setup time
[2004/08/12 09:37:40, 3] smbd/error.c:error_packet(118)
  error packet at smbd/reply.c(389) cmd=117 (SMBtconX) 
NT_STATUS_BAD_NETWORK_NAME
[2004/08/12 09:37:40, 5] lib/util.c:show_msg(456)
[2004/08/12 09:37:40, 5] lib/util.c:show_msg(466)
  size=35
  smb_com=0x75
  smb_rcls=204
  smb_reh=0
  smb_err=49152
  smb_flg=136
  smb_flg2=51201
  smb_tid=0
  smb_pid=65279
  smb_uid=129
  smb_mid=42817
  smt_wct=0
  smb_bcc=0
[2004/08/12 09:37:40, 6] lib/util_sock.c:write_socket(432)
  write_socket(5,39)
[2004/08/12 09:37:40, 6] lib/util_sock.c:write_socket(435)
  write_socket(5,39) wrote 39
[2004/08/12 09:37:41, 10] lib/util_sock.c:read_smb_length_return_keepalive(488)
  got smb length of 108
[2004/08/12 09:37:41, 6] smbd/process.c:process_smb(889)
  got message type 0x0 of len 0x6c
[2004/08/12 09:37:41, 3] smbd/process.c:process_smb(890)
  Transaction 11637 of length 112

Comment 7 Robert Edstrom 2004-09-19 19:37:53 UTC
Any progress?  Well, I kinda put samba on the back burner for now because I am 
working on multiple projects.  I ended up completely upgrading the server's 
hard disks.  I installed a larger hard drive so I wiped out the OS reinstalled, 
and this time partitioned with LVM.

Anyway, I upgraded samba to 3.0.6 and at first everything looked ok.  It took 
me a while to get used to the new samba 3.x schema as I previously ran samba 
3.x using ldapsam_compat and the historical schema.  I still have problems with 
the home drive, but the problem has modified slightly.  The Homes share gets 
mapped, but sometimes it gets mapped to the Print$ share instead.  What I mean 
is that When I open up Homes, I get the same files and folders that are in my 
Print$ share.  I know 3.0.7 is out and I have yet to try it.

Does anyone else see this behavior?
Robert.
Comment 8 Gerald (Jerry) Carter 2005-02-09 08:59:59 UTC
I think this is fixed in 3.0.11.  I remember working on 
a similar bug.
Comment 9 Gerald (Jerry) Carter 2005-08-24 10:17:45 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.