Bug 1585 - smbcacls - inherit problem
Summary: smbcacls - inherit problem
Alias: None
Product: Samba 3.0
Classification: Unclassified
Component: File Services (show other bugs)
Version: 3.0.5
Hardware: All Linux
: P3 normal
Target Milestone: none
Assignee: Samba Bugzilla Account
QA Contact: Samba QA Contact
Depends on:
Reported: 2004-08-04 08:04 UTC by Bartosz Bankowski (mail address dead)
Modified: 2020-12-20 15:19 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Bartosz Bankowski (mail address dead) 2004-08-04 08:04:17 UTC
I've got directory "a" and file "b" inside. I'm trying to add ACE to "a":
smbcacls -a "ACL:MYDOMAIN\myuser:ALLOWED/3/CHANGE -A samba //win2k/dir a

There are two problems:
1) when viewing by Windows clients - there is a message that permissions order 
is incorrect
2) new ACE isn't inherited by file "b"

Fixing the first problem (by patching smbcacls.c) hasn't solved the second.
Comment 1 Tim Otten 2004-09-26 12:15:54 UTC
I'm writing a script which uses a nearly identical command, and my Windows
system shows the same error message (#1). I found these comments which seem to
be related:


My Linux box has Debian/sarge and Samba 3.0.7, and the Windows box runs 2003.

What patch was tried against smbcacls.c?
Comment 2 Bartosz Bankowski (mail address dead) 2004-09-27 00:27:02 UTC
> What patch was tried against smbcacls.c?

The one I've found here:
Comment 3 Stefan Metzmacher 2010-04-26 03:37:51 UTC
If it's still broken in 3.5, please reopen.
3.0 isn't supported anymore.
Comment 4 Volker Lendecke 2010-04-26 03:39:36 UTC
Bugs with patches should be kept open IMO
Comment 5 Björn Jacke 2020-12-20 15:19:11 UTC
4.14 will have 0248fdd09a68925e3720f67724463f0bce0d631a (add new '--propagate-inheritance' option for smbcacls). If current master or 4.14 does not work for you ,please reopen this bug.