Bug 1537 - smbclient's quotation processing behaves odd, leading to incorrect commands
smbclient's quotation processing behaves odd, leading to incorrect commands
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: smbclient
3.0.4
x86 Linux
: P3 critical
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-16 10:07 UTC by Reinhard Nißl
Modified: 2005-08-24 10:21 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Reinhard Nißl 2004-07-16 10:07:09 UTC
It seems that smbclient supports two quotation chars (>>"<< and >>'<<), but it
doesn't take into account, which character started a quotation. Therefore, it is
impossible to get files like >>john's letter.txt<<.

smb: \> get "john's letter.txt"
NT_STATUS_OBJECT_NAME_NOT_FOUND opening remote file \johns
smb: \>

Furthermore, it is impossible to get files whose name contains a >>;<< directly
on the command line, as the commands are broken on any >>;<<, ignoring any
quotation.

platon:~ # smbclient //host/share password -U user -W domain -c 'get "x;y.txt"'
Domain...
NT_STATUS_OBJECT_NAME_NOT_FOUND opening remote file \x
y.txt: command not found

I consider this bug to be critical, as one may loose data when using the 'del'
command and there is a file named >>x<< in the above example.
Comment 1 Gerald (Jerry) Carter 2004-08-08 14:18:15 UTC
I think this is fixed in 3.0.6rc2.  It was a bug caused by using " 
and ' as token separators.
Comment 2 Gerald (Jerry) Carter 2004-08-08 14:18:49 UTC
marking as fixed.
Comment 3 Gerald (Jerry) Carter 2005-08-24 10:21:29 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.