Bug 15189 - Samba 4.5 sometimes cannot be upgraded to Samba 4.6 or later over DRS: WERROR_DS_DRA_MISSING_PARENT due to faulty GET_ANC
Summary: Samba 4.5 sometimes cannot be upgraded to Samba 4.6 or later over DRS: WERROR...
Status: RESOLVED FIXED
Alias: None
Product: Samba 4.1 and newer
Classification: Unclassified
Component: AD: LDB/DSDB/SAMDB (show other bugs)
Version: 4.17.0
Hardware: All All
: P5 normal (vote)
Target Milestone: ---
Assignee: Jule Anger
QA Contact: Samba QA Contact
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-09-29 04:56 UTC by Andrew Bartlett
Modified: 2022-10-19 12:25 UTC (History)
1 user (show)

See Also:


Attachments
patch for Samba 4.17 (41.54 KB, patch)
2022-10-04 21:55 UTC, Andrew Bartlett
jsutton: review+
abartlet: ci-passed+
Details
Patch for Samba 4.16 (41.54 KB, patch)
2022-10-04 21:57 UTC, Andrew Bartlett
jsutton: review+
abartlet: ci-passed+
Details
Patch for Samba 4.12 (44.31 KB, patch)
2022-10-05 00:35 UTC, Andrew Bartlett
jsutton: review+
abartlet: ci-passed+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Bartlett 2022-09-29 04:56:45 UTC
This bug is to work to have a method to upgrade, using DRS replication, from very old versions of Samba to a modern version.

While this doesn't happen often, the situation is easy to replicate and easy to work around, so I would like for us to support it.
Comment 1 Samba QA Contact 2022-10-04 03:49:13 UTC
This bug was referenced in samba master:

62b426243f4eaa4978c249b6e6ce90d35aeaefe4
7ff743d65dcf27ffe0c6861720e8ce531bfa378d
314bc44fa9b8fc99c80bfcfff71f2cec67bbda36
b0bbc94d4124d63b1d5a35ccbc88ffd51d520ba0
483c48f52d6ff5e8149ed12bfeb2b6608c946f01
bff2bc9c7d69ec2fbe9339c2353a0a846182f1ea
Comment 2 Andrew Bartlett 2022-10-04 21:55:07 UTC
Created attachment 17536 [details]
patch for Samba 4.17
Comment 3 Andrew Bartlett 2022-10-04 21:57:30 UTC
Created attachment 17537 [details]
Patch for Samba 4.16
Comment 4 Andrew Bartlett 2022-10-05 00:35:53 UTC
Created attachment 17538 [details]
Patch for Samba 4.12

This patch is intended to go on top of Catalyst's Samba 4.12 backport tree found here: https://gitlab.com/catalyst-samba/samba/-/tags/catalyst-4.12-backports-2022-09
Comment 5 Andrew Bartlett 2022-10-06 23:57:20 UTC
To be specific, this is about WERROR_DS_DRA_MISSING_PARENT as seen at https://lists.samba.org/archive/samba/2018-February/213871.html

The issue is that there is a parent/child/grandchild relation where the 'child' object is not marked isCriticalSystemObject but the parent and grandchild are.

We now work around this simply by jumping to full replication right away.
Comment 6 Jule Anger 2022-10-07 08:45:44 UTC
Pushed to autobuild-v4-{17,16}-test.
Comment 7 Samba QA Contact 2022-10-07 09:57:24 UTC
This bug was referenced in samba v4-16-test:

2003f7cf7497d8a0dfc11c230c8f3a28c53eea64
70de610892409421aeb9047b26a551881966acdc
6e217c047d2123e27e735aa7b168f564d0b719e6
fba1864d7a74e82676bf55a8c162ead90adb445c
6a6db20068fb28cbc3b70a92b0b51d08621272c5
42b5bfa68e25a2878bc0f441061a2e8195874573
dd2c5f96981e6ea06447490dbf65d883134060b2
2d2156b01dea36fdac02fdd6bb5f2e36ef81d2b7
997b8f8341f27919b0ae24d24680637f14406d54
a0e0c7e9894f8c3ff073dbff1a7e77e9a6b2f06b
584a4c005751e3964d070e40573f8620706fc647
0a8330ab7dc2bad3b2ab24dc5e5e368b3979ea05
1a4d3a2db79dbf48b772b7bbbcf5988a43958642
Comment 8 Samba QA Contact 2022-10-07 10:00:28 UTC
This bug was referenced in samba v4-17-test:

02ededec93832164c492a676e95c138fd091c332
4486028b86eed21d70cda862a3e54c907d43a5f5
79b5156ec816a0f54029c576d687797a1c26df1b
ad768b1ccac35d096116d1134c8d50db8d4dcd92
6cc1ac327a0b47eb73da8a372a8fa5e8a4786b64
e80ec63f746f7f220c19b5c3a6a80b0ebd690240
4425351fbffccd2ac3cee6ef1231979c90489bf5
6671f6f50c30d867b637a0fba8ee4d5798dc057d
7bde5d32bf79329b6d598aef3ec5295582734313
a64c4a7e04d35dcaca4ed1e034d947ca349e82f3
eb939d4b805148ae8296db853588b9c4760fa99d
79283760616bdd1ae811f8c407d601dfc48f019e
bac9532f0a98ad54d4ad00f94bcbf13c797f823d
Comment 9 Jule Anger 2022-10-07 13:09:31 UTC
Closing out bug report.

Thanks!
Comment 10 Samba QA Contact 2022-10-19 12:25:29 UTC
This bug was referenced in samba v4-17-stable (Release samba-4.17.1):

02ededec93832164c492a676e95c138fd091c332
4486028b86eed21d70cda862a3e54c907d43a5f5
79b5156ec816a0f54029c576d687797a1c26df1b
ad768b1ccac35d096116d1134c8d50db8d4dcd92
6cc1ac327a0b47eb73da8a372a8fa5e8a4786b64
e80ec63f746f7f220c19b5c3a6a80b0ebd690240
4425351fbffccd2ac3cee6ef1231979c90489bf5
6671f6f50c30d867b637a0fba8ee4d5798dc057d
7bde5d32bf79329b6d598aef3ec5295582734313
a64c4a7e04d35dcaca4ed1e034d947ca349e82f3
eb939d4b805148ae8296db853588b9c4760fa99d
79283760616bdd1ae811f8c407d601dfc48f019e
bac9532f0a98ad54d4ad00f94bcbf13c797f823d