Bug 15133 - Dolphin access to network storage returns file does not exist
Summary: Dolphin access to network storage returns file does not exist
Alias: None
Product: Samba 4.1 and newer
Classification: Unclassified
Component: File services (show other bugs)
Version: 4.15.7
Hardware: x64 Linux
: P5 normal (vote)
Target Milestone: ---
Assignee: Samba QA Contact
QA Contact: Samba QA Contact
Depends on:
Reported: 2022-07-31 02:13 UTC by hrm-temp@sonic.net
Modified: 2022-08-08 03:37 UTC (History)
0 users

See Also:

Various log files (113.03 KB, text/plain)
2022-07-31 02:13 UTC, hrm-temp@sonic.net
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description hrm-temp@sonic.net 2022-07-31 02:13:48 UTC
Created attachment 17451 [details]
Various log files

Overview: System is openSUSE Leap 15.4, KDE, up to date. I have a 10TB external hard drive connected to a router, accessed as smb:// The drive has three NTFS partitions. Until recently all our machines could access all the partitions from both Windows 10 and openSUSE. Now all partitions are acting very strangely with Leap. Accessing a network file via Dolphin after a period of inactivity works correctly for usually four or five files. After that, Dolphin starts the correct application, but gives an error message that the file "does not exist". Refreshing the Dolphin folder sometimes will then access the file OK, but usually not. In the Dolphin partition properties window, having it calculate the size gives a different number with each refresh, and only about half the correct size, and sometimes reports the partition does not exist. This issue is also present accessing from a Leap 15.3 system. There is no problem accessing the partitions from Windows 10 with several machines. Also, when I removed the drive from the router and USB connected it to Leap 15.4, everything was fine with all partitions, checked with both fsck and chkdsk. Putting the drive back on the router gave the same strange behavior.

Steps to Reproduce:In Dolphin, navigate to smb:// then to files in any of the three partitions. Click files to open them.

Actual Results: After opening four or five files, Dolphin starts the correct application, but gives an error message that the file "does not exist". This happens with all file types, videos, text, pdf.

Expected Results: Dolphin starts the correct application, and opens the file.

Build Date & Hardware:
Dolphin Version 21.12.3
samba 4.15.7+git.376.dd43aca9ab2-150400.3.5.3

Operating System: openSUSE Leap 15.4
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.14.21-150400.24.11-default (64-bit)
Graphics Platform: X11
Processors: 4 × AMD FX(tm)-4300 Quad-Core Processor
Memory: 7.7 GiB of RAM
Graphics Processor: AMD CEDAR

Additional Builds and Platforms:
Same bad behavior on Leap 15.2 and 15.3
Works correctly on Windows 10.

Additional Information:
Attachment section VLC-fail.txt is a log file from a failed attempt to play a video from the network storage. In it, line 49 is:
main debug: no access modules matched

Attachment section VLC-OK.txt is a log file from successfully playing a video from the network storage. In it, line 154 is:
main debug: using access module "smb"

Attachment section Dolphin10.txt is a Dolphin log with DebugLevel 10. In it, the file in folder "Scuba" played correctly. The file in folder "Holidays" failed.
Comment 1 Rowland Penny 2022-07-31 19:24:10 UTC
(In reply to hrm-temp@sonic.net from comment #0)

'I have a 10TB external hard drive connected to a router, accessed as smb://'

I do not know what router you have, but it is likely to be using an ancient version of Samba and will probably only understand SMBv1.

'The drive has three NTFS partitions.'

Why NTFS ? Also, your router will probably have an old version of ntfs-3g.

Does everything work as expected if the drive is plugged into the LEAP system ?
Comment 2 hrm-temp@sonic.net 2022-07-31 22:43:49 UTC
Router is ASUS RT-AX56U, purchased in September 2020. It runs Asuswrt-Merlin firmware, currently version 386.7_2, the latest.

For Samba protocol versions the router offers SMBv1, SMBv2, and SMBv1+SMBv2. It has always been set to SMBv2.

The drive of course came formatted NTFS. Several of the network machines that access the drive run Windows 10, so I stayed with NTFS. I cannot find how to identify the version of ntfs-3g the router uses. It is stated as "enhanced NTFS performance (through the proprietary drivers used by Asus from either Paragon or Tuxera)".

Until about two weeks ago, everything worked as expected if the network drive was accessed from a Leap 15.3 or 15.4 system. Everything now works as expected if the network drive is accessed from a Windows 10 system. Everything now works as expected if the drive is removed from the router and USB-connected to a Leap 15.4 system.

I have been unable to find what changed to cause this access trouble.
Comment 3 hrm-temp@sonic.net 2022-08-01 17:44:07 UTC
It is not an NTFS issue. I connected a second external drive formatted ext4 to the router. This second drive had the same trouble. Four files started correctly, then all types failed to start.
Comment 4 hrm-temp@sonic.net 2022-08-02 04:37:43 UTC
The problem exists in the combination of Leap and the ASUS router. I accessed the external drive on the ASUS router from a Windows 10 system, and numerous files of various types all opened correctly. I immediately accessed the drive from a Leap 15.4 system, and the first two files opened OK, but then any others were reported as not existing.

I connected the drive to an older Buffalo router, and accessing files from a Leap 15.4 system worked fine.

How can I save logs from samba or Dolphin to try to see the problem?
Comment 5 Rowland Penny 2022-08-02 06:48:05 UTC
(In reply to hrm-temp@sonic.net from comment #4)
So, everything works until you use your ASUS router. This would seem to point to your router being the problem, or part of the problem. I think your major problem is Dolphin and not Samba.
Comment 6 hrm-temp@sonic.net 2022-08-03 00:37:09 UTC
(In reply to Rowland Penny from comment #5)
Maybe not Dolphin. The same trouble occurs with Leap 15.4 when using Krusader Version 2.7.2 and Konqueror Version 21.12.3. Also occurs with Q4OS (Debian GNU/Linux 11) using Krusader Version 2.7.2 and Konqueror Version 20.12.0.
Comment 7 hrm-temp@sonic.net 2022-08-03 00:48:05 UTC
(In reply to Rowland Penny from comment #5)
When VLC fails trying to play a video file, the vlc log states:
"smb error: open failed for ' Art Museum/Event Recording - Art Escapes, Ep. 2 - Development of Buddhist and Hindu Sculpture-U3nErDvplvQ.mkv' (Invalid argument)"
Comment 8 hrm-temp@sonic.net 2022-08-07 16:43:33 UTC
I'm now convinced that the router hardware was failing. In the past few days, it dropped WiFi connections a fair amount, which was new. A new router is installed and running. With the new router, everything now behaves as it did with the old router until a few weeks ago. With Dolphin, click any type file on the router's USB drive, and the appropriate application opens it.

It remains a complete mystery to me why Windows 10 never had trouble accessing the drive on the old router, but several Linux distributions failed.