Bug 1512 - 3.0.5rc1 smbd core
3.0.5rc1 smbd core
Product: Samba 3.0
Classification: Unclassified
Component: File Services
: P3 regression
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2004-07-09 12:03 UTC by g.fischer@ah-online.com
Modified: 2005-08-24 10:16 UTC (History)
0 users

See Also:

make sure we use builtin unix98 printf (459 bytes, patch)
2004-08-02 01:07 UTC, James Peach (outdated mail address)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description g.fischer@ah-online.com 2004-07-09 12:03:04 UTC

tried mipspro 7.41 and gcc 3.4.1.
-O3 -mips4 and -O3 -mips3.
both the same.
irix 6.5.24.
starting smbd gives core. everytime. all prior versions worked fine.

IRIS3 # dbx smbd
dbx version 7.3.3 (78517_Dec16 MR) Dec 16 2001 07:45:22
*STRIPPED* Executable /usr/samba/sbin/smbd
(dbx) run
Process 368465 (smbd) started
Process 368465 (smbd) stopped on signal SIGSEGV: Segmentation violation
(handled) at [strlen:58 ,0xfa42ec0]
         Source (of
/xlv41/6.5.24m/work/irix/lib/libc/libc_n32_M4/strings/strlen.s) not available
for Process 368465
Comment 1 James Peach (outdated mail address) 2004-08-02 01:07:46 UTC
Created attachment 593 [details]
make sure we use builtin unix98 printf
Comment 2 James Peach (outdated mail address) 2005-01-27 22:48:45 UTC
(In reply to comment #1)
> Created an attachment (id=593) [edit]
> make sure we use builtin unix98 printf

I imagine this bug can be closed, since 3.0.11 is now shipping.
Comment 3 Gerald (Jerry) Carter 2005-01-28 10:41:43 UTC
thanks.  done.
Comment 4 Gerald (Jerry) Carter 2005-02-07 09:56:06 UTC
originally against 3.0.5rc1 (which was 34.0.6rc1 due to the security release).
Comment 5 Gerald (Jerry) Carter 2005-08-24 10:16:56 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.