Bug 15083 - printing problems
Summary: printing problems
Status: NEW
Alias: None
Product: Samba 4.1 and newer
Classification: Unclassified
Component: libsmbclient (show other bugs)
Version: 4.16.1
Hardware: All All
: P5 normal (vote)
Target Milestone: ---
Assignee: Samba QA Contact
QA Contact: Samba QA Contact
Depends on:
Reported: 2022-05-31 11:20 UTC by Dmitry Karasik
Modified: 2022-05-31 11:20 UTC (History)
0 users

See Also:

archive of the logs (15.94 KB, application/x-compressed-tar)
2022-05-31 11:20 UTC, Dmitry Karasik
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Karasik 2022-05-31 11:20:55 UTC
Created attachment 17314 [details]
archive of the logs


I cannot print to a previously available printer that I don't unfortunately
have any idea what happened to. Quite possible its admin did some changes.

Here's what I observe:

1. Using smbclient I connect to the printer and issue a command 'print
test.txt'.  Then I go to the physical printer to login with company-issued safe
card, and I see my job there as 'Remote Downlevel Document'. However if I
press on "print" there, the printer starts buzzing, but nothing comes out. I tried also pdfs, same effect (Also just to be 100% sure, printing from a domain windows machine works fine).

2. Guessing there's some queuing issues, I issue a command `queue` but get this

smb1cli_req_writev_submit: called for dialect[SMB3_11]

3. I tried to set various minimal and maximal versions in smb.conf, but result always was the same, both for `queue` and `print` commands.

4. I grabbed the latest samba distribution, ran the same commands under
smbclient -d10, while also recording tcpdump between the client and the
printer. The latest smbclient tried also to open an unexistent
/usr/local/samba/etc/smb.conf, but the result was same, too.

Kindly advise what could be done here

Dmitry Karasik

The attached files:
[1] smb.d10 - smbclient log with -d10
[2] smb.login - tcpdump for smbclient logging in session
[3] smb.print - tcpdump after I typed the 'print' command
[4] print.pcapng - wireshark dump after I typed the 'print' command
[5] test.txt - the file that was sent to the printer
[6] smb.conf - just in case

I'm not attaching login.pcapng because I don't know how to doctor out my login and password from there. I did that manually for smb.login though.

I'm attaching the files as an archive but I also uploaded them to my website: http://karasik.eu.org/misc/smb/