Bug 1507 - Very slow performence writing within some word documents in a samba share.
Very slow performence writing within some word documents in a samba share.
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.4
PPC AIX
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-05 14:25 UTC by Allan H. Nielsen
Modified: 2005-08-24 10:21 UTC (History)
3 users (show)

See Also:


Attachments
Specific MS word document formatted with tables. (119.50 KB, application/msword)
2004-07-05 14:29 UTC, Allan H. Nielsen
no flags Details
Network trace between Win 2k client and Samba server (289.64 KB, application/x-gzip)
2004-07-05 14:51 UTC, Allan H. Nielsen
no flags Details
Samba debug 10 log (747.09 KB, text/plain)
2004-07-05 14:57 UTC, Allan H. Nielsen
no flags Details
smb.conf (1.50 KB, text/plain)
2004-07-05 15:02 UTC, Allan H. Nielsen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Allan H. Nielsen 2004-07-05 14:25:27 UTC
Production environment is Samba-2.0.7 on AIX 5.1 in a NT4 domain with mutually
trusts to an ADS domain where users are defined. 
Test environment is Samba-3.0.4 in a NT4 based domain where problem can be
reproduced. We experience serious performence problems on some Word documents
having tables. Opening takes long time compared with other files and editing
within the document is a pain as just moving the mouse curser to another
table-cell takes up to several minutes. Net-traces indicates that oplocks are
broken and that local caching of file is not effective. With "Veto oplock file"
set to *.xls we cannot reproduce the same strange behavour with excel files so
problem seems to be isolated to Word docs with special formatting.
Comment 1 Allan H. Nielsen 2004-07-05 14:29:29 UTC
Created attachment 555 [details]
Specific MS word document formatted with tables.

This MS Word doc formatted with tables is a sample of the documents giving a
very slow response while editing.
Comment 2 Allan H. Nielsen 2004-07-05 14:51:07 UTC
Created attachment 556 [details]
Network trace between Win 2k client and Samba server
Comment 3 Allan H. Nielsen 2004-07-05 14:57:53 UTC
Created attachment 557 [details]
Samba debug 10 log

Action takes place within the first 10 Mb of the trace.
Trace taken at the same time as the network trace
Comment 4 Allan H. Nielsen 2004-07-05 15:02:50 UTC
Created attachment 558 [details]
smb.conf

Only smb.conf from a 2.2.6 version available at this time but this has been
used as a base for 3.0.4 where winbind parameters were added and "domain" level
security selected instead as "server".
Comment 5 Joergen Berg 2004-07-06 11:21:06 UTC
Hi,

it seems like that setting 

oplocks = NO

in the smb.conf file may work as a workaround, but I so nat know the real 
impact of this setting, having looked true the docu, i could be some problems
in the locking mechanisme SAMBA/WINDOWS/DOS - OR ??

Med venlig hilsen/Kind regards

Jørgen Berg
Senior IT Specialist - FTSS
Deep Computing - Nordic Technical Presale - pSeries
Systems and Technology Group
IBM Danmark A/S

+45 2880 4074  [GSM]
email: jober@dk.ibm.com
Comment 6 Olaf Fraczyk 2005-02-15 02:25:20 UTC
This won't give you locking problems. This causes only that client won't cache
the document on his side. This can give a little performance loss.
But in your case it will make your life easier and performance increase :)
Comment 7 Gerald (Jerry) Carter 2005-02-21 06:18:48 UTC
please retest against 3.0.11 and reopen if necessary.   Thanks.
Comment 8 Gerald (Jerry) Carter 2005-08-24 10:21:26 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.