Bug 1506 - 3.0.4 PDC stops XP Workstation service and others
3.0.4 PDC stops XP Workstation service and others
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
3.0.4
x86 Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-04 07:45 UTC by Stuart Rauh
Modified: 2004-09-08 06:04 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stuart Rauh 2004-07-04 07:45:18 UTC
Small network using Fedora core 1 box as PDC and two XP Pro SP1 boxes as
clients.  Set up with roaming profiles for about four users.

All works well in 3.0.2.  Upgrade to 3.0.4 with same config causes XP boxes to
shut down services at boot.  Notably Workstation service is not running on XP
boxes after a reboot thus breaking roaming profiles.

Numerous other services also not running, like audio services, auto update
services and many seemingly unrelated ones.

This happens on both connected XP machines without any change in configuration
when I apply Samba 3.0.4 to my PDC server.

When I remove 3.0.4 and reinstall 3.0.2, all works fine once again.
Comment 1 Guenther Deschner 2004-07-13 03:58:31 UTC
Reproduced.
Comment 2 Guenther Deschner 2004-07-13 08:43:25 UTC
In my setup it turned out to be a ldap-configuration problem (too long delays
for enumerating groups (1,5sec.)). Once fixed, XP was doing logons as expected
again. net rpc group members <GROUPNAME> is a good tool to check the involved
calls for group-enumeration. (Thanks Volker !).

If the problem still persists, could you please check possible
ldap-configuration issues?
Comment 3 Stuart Rauh 2004-07-13 21:54:13 UTC
I'm not using LDAP.  Small network here so had no need so far to set it up.  
Just using smbpasswd user accounts.  I've reverted to 3.0.2 on my server and 
all works fine.

I do have group mapping issues but it's always worked in older versions.  I've 
been unable to understand properly mapping XP groups to Linux.  Tried the 
steps in the how to but still get errors in the log.

I will try again to get the mappings correct in case that's what it causing 
the trouble.  I don't think this is the problem since 3.0.2 works with the 
same configuration.

I will be happy to help test this any way I can.  Let me know what you need.
Comment 4 Ian Kahan 2004-09-06 12:36:16 UTC
I experienced the same using samba 3.0.5 and 3.0.6.

In addition to that the initial access to a share was noticeably slow (after 
manually starting all the network services). That means that the very first 
access to a share via windows explorer took about 10-15 sec.

Only  XP clients were afected from the failed startup of services (server, 
workstation, computer browser...). Win2000 clients launched the services 
without any error but were only slow at initial share accesses.


It finally turned out to be a problem with WINS name resolution.


A freshly booted XP coputer with the abouve symptoms (services failed..) 
showed up a wrong ip adress when pinging the samba pdc. as the pdc was 
correctly listed in dns, it could be resolved in windows explorer with a 
latecy of the mentioned 10-15 sec.
Suprisingly sometimes pinging the pdc after approximately 15min worked out 
fine..

The reason wich caused this error was a double entry in wins.dat. the samba 
pdc was listed there twice with two different ip addresses - a wrong one and a 
correct one.
In most of the cases nmbd was replying with the wrong ip when querying for the 
pdc's address. That seems to have made the services fail at windows startup 
(timeout).

I shutted down all client computers, stopped nmbd and deleted the wins.dat. 
After  relaunching nmbd and booting the client machines again, the file was 
filled with corect entries.

The symptoms completely dissapeared.


Stuart, maybe you should check if it was an issue similar to mine. Check if 
the ip address of your samba pdc can be resolved correctly via WÍNS and DNS.

Regards,
Ian
 

Comment 5 Stuart Rauh 2004-09-07 19:21:57 UTC
Thank you Ian.  I'm running 3.0.6 now and was seeing the slow response issue 
you mentioned.  I deleted the wins.dat file as you suggested and things seem 
to be more responsive now.  I'll have to watch it for a while.

Stuart Rauh
Comment 6 Gerald (Jerry) Carter 2004-09-08 06:04:36 UTC
bad wins entry.  no source bug.