Bug 15032 - Unable to authenticate Android Solid Explorer after upgrading to 4.15.6
Summary: Unable to authenticate Android Solid Explorer after upgrading to 4.15.6
Status: NEW
Alias: None
Product: Samba 4.1 and newer
Classification: Unclassified
Component: File services (show other bugs)
Version: 4.15.6
Hardware: All Linux
: P5 normal (vote)
Target Milestone: ---
Assignee: Samba QA Contact
QA Contact: Samba QA Contact
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-03-24 07:11 UTC by Frederick Zhang
Modified: 2022-03-25 06:52 UTC (History)
0 users

See Also:


Attachments
Logs (level 10) when Solid Explorer tried to connect (59.32 KB, text/x-log)
2022-03-24 07:11 UTC, Frederick Zhang
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederick Zhang 2022-03-24 07:11:03 UTC
Created attachment 17239 [details]
Logs (level 10) when Solid Explorer tried to connect

I'm using Arch Linux and recently upgraded to 4.15.6 from 4.15.5. After
this upgrade, one of my Samba clients, Solid Explorer 2.8.19 on Android,
is no longer able to authenticate itself.

I did a bisect and narrowed it down to c0795f1:

# bad: [8942e18adc466198203cb3f24c0556c590f44e96] VERSION: Disable GIT_SNAPSHOT for the 4.15.6 release.
# good: [27bd8a323591486e76e916a6084c7300bf358eec] VERSION: Disable GIT_SNAPSHOT for the 4.15.5 release.
git bisect start 'samba-4.15.6' 'samba-4.15.5'
# bad: [a2fe8bf5a5d0889dc53697904fd647812dc74c8c] s3/libads: simplify storing existing ads->ldap.ss
git bisect bad a2fe8bf5a5d0889dc53697904fd647812dc74c8c
# good: [4a6c8349c39eda9fa39ee3e7eb33ace37d391bad] blackbox.ndrdump: adjust example files to changed dump_data() output.
git bisect good 4a6c8349c39eda9fa39ee3e7eb33ace37d391bad
# bad: [641271eaa076cfbebdc22e472e57a088ef88a298] s4: test: Add samba4.libsmbclient.rename test. Currently fails for SMB3.
git bisect bad 641271eaa076cfbebdc22e472e57a088ef88a298
# bad: [c0795f1a6348048c849b853c5c6e0cbc7b002daa] librpc/ndr: let ndr_push_string() let s_len == 0 result in d_len = 0
git bisect bad c0795f1a6348048c849b853c5c6e0cbc7b002daa
# good: [318266fcedb1ddd20725e92207e681a31bd6537b] ndrdump: make use of dump_data_file_diff() in order to show differences
git bisect good 318266fcedb1ddd20725e92207e681a31bd6537b
# good: [cb7e6f0e7fbaa944412d167adbe06fb6057cb370] s4:torture/ndr: demonstrate the ndr_push_string(STR_NOTERM|REMAINING) of "" is wrong
git bisect good cb7e6f0e7fbaa944412d167adbe06fb6057cb370
# first bad commit: [c0795f1a6348048c849b853c5c6e0cbc7b002daa] librpc/ndr: let ndr_push_string() let s_len == 0 result in d_len = 0

And I can confirm this issue still persists using Samba 4.16.0. I also
tested reverting the commit in question on top of 4.15.6, and Solid
Explorer was able to connect and authenticate again after reverting.

I'm not totally sure if this is a Samba issue or a Solid Explorer one,
since my other clients work normally with Samba 4.15.6 (and the commit
actually made sense to me). Sorry if this is not the right place and
I'll redirect this issue report to Solid Explorer developers instead
in that case.
Comment 1 Jeremy Allison 2022-03-24 17:08:59 UTC
Looks like a Solid Explorer bug IMHO. Can you also report to them please ?
Comment 2 Frederick Zhang 2022-03-25 06:52:13 UTC
Of course, Jeremy. I've sent an email to bugs@neatbytes.com.