Bug 14976 - samba --use-kerberos option fails with net ads command
Summary: samba --use-kerberos option fails with net ads command
Status: NEW
Alias: None
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Tools (show other bugs)
Version: 4.15.5
Hardware: All All
: P5 normal (vote)
Target Milestone: ---
Assignee: Samba QA Contact
QA Contact: Samba QA Contact
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-02-12 22:43 UTC by Jason Keltz
Modified: 2022-02-12 22:43 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Keltz 2022-02-12 22:43:37 UTC
Samba 4.15.5 changed the format of -k to --use-kerberos=required.
This format works with samba-tool, but it does not work with net...
eg. net ads leave -k worked with 4.15.4 but net ads leave --use-kerberos=required does not work (net prompts for password even though the user is already authenticated).