Bug 1494 - compiling 3.0.4 as well as 2.2.9 on solaris 8 erroring out
compiling 3.0.4 as well as 2.2.9 on solaris 8 erroring out
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.4
Sparc Solaris
: P3 regression
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-30 11:25 UTC by Mark
Modified: 2005-08-24 10:18 UTC (History)
0 users

See Also:


Attachments
config.log (377.76 KB, text/plain)
2004-06-30 11:28 UTC, Mark
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark 2004-06-30 11:25:43 UTC
running on 5.8 Generic_108528-21 sun4u sparc SUNW,Sun-Blade-100 , gcc 3.0

used
./configure --prefix=/opt/sw/samba/3.0.4 --with-acl-support --with-syslog 

with environmental flags
LD_LIBRARY_PATH=/opt/sw/openssl/current/lib:/opt/sw/zlib/current/lib
LDFLAGS=-L/opt/sw/openssl/current/lib
CPPFLAGS=-I/opt/sw/openssl/current/include

make proto works....then make doesnt..... tried 2.2.9..same result..same place

>make proto

make delheaders; \
make smbd/build_options.c; \
make include/proto.h; \
make include/build_env.h; \
make include/wrepld_proto.h; \
make nsswitch/winbindd_proto.h; \
make web/swat_proto.h; \
make client/client_proto.h; \
make utils/net_proto.h
make[1]: Entering directory `/root/source/samba-3.0.4/source'
Removing prototype headers
make[1]: Leaving directory `/root/source/samba-3.0.4/source'
make[1]: Entering directory `/root/source/samba-3.0.4/source'
Generating smbd/build_options.c
make[1]: Leaving directory `/root/source/samba-3.0.4/source'
make[1]: Entering directory `/root/source/samba-3.0.4/source'
Building include/proto.h
creating /root/source/samba-3.0.4/source/include/proto.h
make[1]: Leaving directory `/root/source/samba-3.0.4/source'
make[1]: Entering directory `/root/source/samba-3.0.4/source'
Building include/build_env.h
make[1]: Leaving directory `/root/source/samba-3.0.4/source'
make[1]: Entering directory `/root/source/samba-3.0.4/source'
Building include/wrepld_proto.h
creating /root/source/samba-3.0.4/source/include/wrepld_proto.h
make[1]: Leaving directory `/root/source/samba-3.0.4/source'
make[1]: Entering directory `/root/source/samba-3.0.4/source'
creating /root/source/samba-3.0.4/source/nsswitch/winbindd_proto.h
make[1]: Leaving directory `/root/source/samba-3.0.4/source'
make[1]: Entering directory `/root/source/samba-3.0.4/source'
creating /root/source/samba-3.0.4/source/web/swat_proto.h
make[1]: Leaving directory `/root/source/samba-3.0.4/source'
make[1]: Entering directory `/root/source/samba-3.0.4/source'
creating /root/source/samba-3.0.4/source/client/client_proto.h
make[1]: Leaving directory `/root/source/samba-3.0.4/source'
make[1]: Entering directory `/root/source/samba-3.0.4/source'
creating /root/source/samba-3.0.4/source/utils/net_proto.h
make[1]: Leaving directory `/root/source/samba-3.0.4/source'

>make

Using FLAGS =  -O -I./popt -Iinclude -I/root/source/samba-3.0.4/source/include -
I/root/source/samba-3.0.4/source/ubiqx -I/root/source/samba-
3.0.4/source/smbwrapper  -I. -I/opt/sw/openssl/current/include -
D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/local/include -
I/root/source/samba-3.0.4/source    
      LIBS = -lsec -lgen -lresolv -lsocket -lnsl -ldl -liconv
      LDSHFLAGS = -G  -L/opt/sw/openssl/current/lib -L/usr/local/lib
      LDFLAGS = -L/opt/sw/openssl/current/lib -L/usr/local/lib
Compiling dynconfig.c
In file included from nsswitch/winbind_nss_solaris.h:28,
                 from nsswitch/winbind_nss.h:34,
                 from nsswitch/winbind_nss_config.h:79,
                 from nsswitch/winbind_client.h:1,
                 from include/includes.h:835,
                 from dynconfig.c:21:
/usr/include/nss_dbdefs.h:375: parse error before "projid_t"
/usr/include/nss_dbdefs.h:400: parse error before '}' token
/usr/include/nss_dbdefs.h:419: field `key' has incomplete type
make: *** [dynconfig.o] Error 1
Comment 1 Mark 2004-06-30 11:28:11 UTC
Created attachment 550 [details]
config.log
Comment 2 Mark 2004-07-19 13:36:28 UTC
any update? as of when someone might take a look at it?
Comment 3 Gerald (Jerry) Carter 2004-07-20 09:16:48 UTC
Compile ok on Solaris 9 x86.  Will have to build a Solaris 8 
machine to check  on that platform.  What compiler are you using btw....
Comment 4 Mark 2004-07-20 11:02:19 UTC
gcc -v
Reading specs from /usr/local/lib/gcc-lib/sparc-sun-solaris2.8/3.0/specs
Configured with: ../configure --disable-nls --disable-libgcj --enable-
languages=c++,f77,objc
Thread model: posix
gcc version 3.0


just downloaded from sunfreeware.com built binary gcc pkg


(In reply to comment #3)
> Compile ok on Solaris 9 x86.  Will have to build a Solaris 8 
> machine to check  on that platform.  What compiler are you using btw....

Comment 5 Mark 2004-08-04 17:36:55 UTC
anyone making any leadway on this?
Comment 6 Gerald (Jerry) Carter 2005-02-11 08:12:40 UTC
cannot reproduce against 3.0.11.  Please rests against that 
version and reopen if necessary.
Comment 7 Gerald (Jerry) Carter 2005-08-24 10:18:32 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.