Bug 1490 - tar in smbclient produces double output in certain cases
tar in smbclient produces double output in certain cases
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: smbclient
3.0.4
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-29 07:45 UTC by marko
Modified: 2004-08-26 06:17 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description marko 2004-06-29 07:45:21 UTC
When there are files with accented letters, and tar is run in the directory
whilst using smbclient by calling the files directly, it works fine.

If calling files using wildcards: ie. tar -c foo.tar *
tar packs both the correct filenames and same files with their filenames
garbled, producing double output for each filename with accented characters.
Comment 1 Björn Jacke 2004-07-07 17:10:53 UTC
Please give us a concrete example and a how-to-reproduce all this.
Comment 2 marko 2004-08-26 06:17:56 UTC
i'm not having luck reproducing this. it may have been due to the fact that
there were some cp850 files in there that were causing problems.