Bug 14897 - samba process doesn't log to logfile
Summary: samba process doesn't log to logfile
Status: RESOLVED FIXED
Alias: None
Product: Samba 4.1 and newer
Classification: Unclassified
Component: AD: LDB/DSDB/SAMDB (show other bugs)
Version: unspecified
Hardware: All All
: P5 normal (vote)
Target Milestone: ---
Assignee: Jule Anger
QA Contact: Samba QA Contact
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-08 11:37 UTC by Ralph Böhme
Modified: 2021-11-17 07:49 UTC (History)
1 user (show)

See Also:


Attachments
Patch for 4.15 cherry-picked from master (32.76 KB, patch)
2021-11-16 05:22 UTC, Ralph Böhme
asn: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ralph Böhme 2021-11-08 11:37:36 UTC
This is a regression by the fixes for bug 14803. Since then the samba process will always log to stdout and won't default to logging to a file.

Have patches, need bugnumber.
Comment 1 Ralph Böhme 2021-11-08 14:28:12 UTC
This is a regression by the fixes for bug 14803. Since then the samba process will always log to stdout and won't default to logging to a file.
Comment 2 Samba QA Contact 2021-11-11 15:01:57 UTC
This bug was referenced in samba master:

25043ebb2e6f74592e802f78d327f844e615a442
54f54fc2627acbf5fac5e1fa86ab9f743741f3c4
117d45df47a1f3206bc38aaeaa11f2b327e43530
948a82bd2651e73e4e669a89dc77ba93abbb9b2f
fa9d9974d068897d35539e5316f606a15e8b38de
120a598e53173aacc0994318223bdac33dac4fbd
97592f16bfb8590efbd2ed31fc9883d747ec650f
06ed4ccba6cfe08aef061866f98b1d1da26682b8
Comment 3 Ralph Böhme 2021-11-16 05:22:53 UTC
Created attachment 16994 [details]
Patch for 4.15 cherry-picked from master
Comment 4 Andreas Schneider 2021-11-16 08:31:09 UTC
Comment on attachment 16994 [details]
Patch for 4.15 cherry-picked from master

LGTM
Comment 5 Andreas Schneider 2021-11-16 08:31:40 UTC
Jule, could you please apply the patch to 4.15? Thank you very much :-)
Comment 6 Jule Anger 2021-11-16 16:01:16 UTC
Pushed to autobuild-v4-15-test.
Comment 7 Samba QA Contact 2021-11-16 16:57:04 UTC
This bug was referenced in samba v4-15-test:

c9b5ca53eba217d50ed1c0921ac37388b9a624b3
006aa720c549593da73ec704126d1d7b40f1ca0e
9462c39eab8d22a1ffd15dd0ca8aabbfc9e02a28
cda7fb2a0578f2fb809fc134628e89eac616b40f
371c723e4d816c76aa1c41bed94bfb6fda1cbfad
38736e887287cdaa88cb62b489fa9680b0aa94ee
47c00820819df91053ad322935ce69340826e6cd
c357c1b20249d006d1aa4fc33d311e519895135c
Comment 8 Jule Anger 2021-11-17 07:49:50 UTC
Closing out bug report.

Thanks!