Bug 1458 - bigs files get corrupt when transfering from WinXP to a linux Samba server
bigs files get corrupt when transfering from WinXP to a linux Samba server
Product: Samba 3.0
Classification: Unclassified
Component: File Services
x86 Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2004-06-13 15:08 UTC by Pierre COLOMBIER
Modified: 2007-11-02 10:37 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Pierre COLOMBIER 2004-06-13 15:08:20 UTC
I tried to transfer big files (more than 1Go) from a machine with windowsXPpro
to a linux server running Samba.
I did it over a 100M ethernet network.
then i used md5sum to check the files : the files are different (but the size 
is the same)

I tried again and again. same problem.
it seems to happen especially when file size excess 100Mo
in fact, I've never been able to transfer a 1.7Go file without corruption.

usually, only a few bytes get corrupt but this is EXTREMELY harmful with .zip 
or .rar archives ! 

there is no problem with SCP or FTP. so, I think it is a problem in the 
transport protocol. isn't there some error detection algorythm in the SMB 
Comment 1 Pierre COLOMBIER 2004-06-20 00:59:48 UTC
not a samba problem
(was an ethernet problem)
Comment 2 nukq 2007-11-02 10:37:34 UTC
Unfortunately,I have the same problem.
Samba-3.0.20 + FreeBSD6.2

When i copy some big files to the Samba, the file corrupted, the same
size but different MD5