Bug 1449 - username in netbios messages corrupt
username in netbios messages corrupt
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: smbclient
3.0.2a
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-09 17:07 UTC by Jaco Kroon
Modified: 2005-03-29 10:03 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaco Kroon 2004-06-09 17:07:57 UTC
When issueing "smbclient -M somehost", the message is received by that host but
the username comes out as ______g__ or something equally unusable.

This can be confirmed by changing the message command line to something like:

message command = echo %f "@" %m "->" %s >> /tmp/messages

which results in lines such as:

____________________h @ pug -> /tmp/msg.uPZ2fb

where pug is the correct host but user is expected to be "jaco".

Additionally it doesn't look like smbclient honors the -n flag (if I do
"smbclient -M slowcoach -n testy" it still shows up as pug).

If Windows clients sends messages to this host then I get the correct values,
also samba 2.2.x works correctly.
Comment 1 Gerald (Jerry) Carter 2005-03-22 14:51:21 UTC
I think this is fixed in 3.0.12
Comment 2 Jaco Kroon 2005-03-29 10:03:32 UTC
Probably earlier already - I just checked 3.0.10 and it's fixed there already. 
I can't seem to get -n working but that may be due to other issues (I'm running
a WINS server).