Bug 14488 - [WHATSNEW] Minimum python 3.6 for samba 4.14
Summary: [WHATSNEW] Minimum python 3.6 for samba 4.14
Status: RESOLVED FIXED
Alias: None
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Python (show other bugs)
Version: 4.13.0rc3
Hardware: All All
: P5 normal (vote)
Target Milestone: ---
Assignee: Karolin Seeger
QA Contact: Samba QA Contact
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-10 22:18 UTC by Andrew Bartlett
Modified: 2020-09-18 08:34 UTC (History)
1 user (show)

See Also:


Attachments
patch for WHATSNEW for 4.13 (1.51 KB, patch)
2020-09-10 22:21 UTC, Andrew Bartlett
dbagnall: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Bartlett 2020-09-10 22:18:35 UTC
A bug to ensure the new Python 3.6 minimum notice is included in Samba 4.13.

This is also the bug that will be referenced for posterity regarding our decision to remove Python 2.x (2.6 and 2.7) build-time support in case this needs feedback or further discussion.
Comment 1 Andrew Bartlett 2020-09-10 22:21:05 UTC
Created attachment 16219 [details]
patch for WHATSNEW for 4.13

As already extensively discussed on samba-technical.  There were no objections other than for clarity.
Comment 2 Karolin Seeger 2020-09-11 08:39:56 UTC
(In reply to Andrew Bartlett from comment #1)
Pushed to autobuild-v4-13-test, thanks!
Comment 3 Samba QA Contact 2020-09-11 10:00:14 UTC
This bug was referenced in samba v4-13-test:

b3845522bece6565507cdbb1f1e215d320fcc1b0
Comment 4 Samba QA Contact 2020-09-18 08:34:51 UTC
This bug was referenced in samba v4-13-stable:

b3845522bece6565507cdbb1f1e215d320fcc1b0