Bug 1447 - nsswitch/winbind_nss_aix.c:750: `attrlist_t' undeclared
nsswitch/winbind_nss_aix.c:750: `attrlist_t' undeclared
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.4
PPC AIX
: P3 regression
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-09 06:42 UTC by Stefan Rodenstein
Modified: 2005-08-24 10:19 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Rodenstein 2004-06-09 06:42:58 UTC
Hi!

I just downloaded samba-3.0.4 and tried to compile it on AIX 4.3.3
with gcc 2.95.2 using

LDFLAGS="-Wl,-bbigtoc" ./configure --prefix=/bag/samba \
   --mandir=/bag/samba/man \
   --localstatedir=/usr/local/samba/var \
   --with-configdir=/usr/local/samba \
   --with-privatedir=/usr/local/samba/private \
   --with-lockdir=/usr/local/samba/var/locks \
   --with-piddir=/usr/local/samba/var/locks \
   --with-ssl --disable-swat \
   --with-sslinc=/bag/openssl/include --with-ssllib=/bag/openssl

This used to work well in the past, the last time with
samba-3.0.2a.

Now, running make in the 3.0.4 tree first gives some problems with
aud_rec in nsswitch/winbind_nss_aix.c, however, this could be fixed
with an #include <sys/audit.h>.

But when I run make then, I get the following error that I couldn't fix:

rodenss@dilbert:/scratch/samba-3.0.4/source$ make
Using FLAGS =  -O -I./popt -Iinclude -I/scratch/samba-3.0.4/source/include
-I/scratch/samba-3.0.4/source/ubiqx -I/scratch/samba-3.0.4/source/smbwrapper 
-I. -D_LARGE_FILES -I/scratch/samba-3.0.4/source    
      LIBS = 
      LDSHFLAGS = -Wl,-bexpall,-bM:SRE,-bnoentry,-berok  -Wl,-bbigtoc
      LDFLAGS = -Wl,-bbigtoc
Compiling nsswitch/winbind_nss_aix.c with -O2
nsswitch/winbind_nss_aix.c:748: parse error before `*'
nsswitch/winbind_nss_aix.c: In function `wb_aix_attrlist':
nsswitch/winbind_nss_aix.c:750: `attrlist_t' undeclared (first use in this function)
nsswitch/winbind_nss_aix.c:750: (Each undeclared identifier is reported only once
nsswitch/winbind_nss_aix.c:750: for each function it appears in.)
nsswitch/winbind_nss_aix.c:750: `ret' undeclared (first use in this function)
nsswitch/winbind_nss_aix.c:752: parse error before `)'
nsswitch/winbind_nss_aix.c:758: parse error before `)'
nsswitch/winbind_nss_aix.c:762: `AL_USERATTR' undeclared (first use in this
function)
nsswitch/winbind_nss_aix.c: In function `wb_aix_init':
nsswitch/winbind_nss_aix.c:981: structure has no member named `method_version'
nsswitch/winbind_nss_aix.c:981: `SECMETHOD_VERSION_520' undeclared (first use in
this function)
nsswitch/winbind_nss_aix.c:990: warning: assignment from incompatible pointer type
nsswitch/winbind_nss_aix.c:994: warning: assignment from incompatible pointer type
nsswitch/winbind_nss_aix.c:999: warning: assignment from incompatible pointer type
nsswitch/winbind_nss_aix.c:1001: structure has no member named `method_attrlist'
make: *** [nsswitch/winbind_nss_aix.po] Error 1
rodenss@dilbert:/scratch/samba-3.0.4/source$ 



attrlist_t seems to be undeclared and I can't find it anyhwere,
neither in the source nor elsewhere on the AIX machine.

Regards,
Stefan
Comment 1 Tim Potter 2004-07-22 23:31:45 UTC
I've checked in a fix for the SECMETHOD_VERSION_520 problem. 

The attrlist_t stuff is probably 5.3 specific code that doesn't work under 4.3.3
Comment 2 Gerald (Jerry) Carter 2005-02-17 09:37:24 UTC
marking as fixed.  please reopen if there is still an issue in 3.0.11.
Comment 3 Gerald (Jerry) Carter 2005-08-24 10:19:07 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.