Bug 1436 - Remote subdirectories are empty
Summary: Remote subdirectories are empty
Status: RESOLVED FIXED
Alias: None
Product: Samba 3.0
Classification: Unclassified
Component: smbclient (show other bugs)
Version: 3.0.4
Hardware: All Linux
: P3 normal
Target Milestone: none
Assignee: Samba Bugzilla Account
QA Contact: Samba QA Contact
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-06-06 23:49 UTC by Jochen Wiedmann
Modified: 2006-04-10 03:21 UTC (History)
0 users

See Also:


Attachments
smb.conf (755 bytes, text/plain)
2004-06-06 23:52 UTC, Jochen Wiedmann
no flags Details
Log file (10.35 KB, text/plain)
2004-06-06 23:52 UTC, Jochen Wiedmann
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jochen Wiedmann 2004-06-06 23:50:00 UTC
Hi,

I have a Fedora Core 2 Linux machine running Samba 3.0.3. Also tried
Samba 3.0.4, with the same results.

I am connecting to a remote Windows 2000 machine using smbclient or
smbmount. I am successfully connecting. A "dir" on the shares top level
directory works fine. However, if I change to any sub directory, it's
empty:

    $ smbclient 2>/tmp/9.log -d 9 -W EUR -U jwi //stujsr01/JUSTUS
    Password:
    smb: \> cd STUJSR01_Justus-Transfer
    smb: \STUJSR01_Justus-Transfer\> dir
      .   D        0  Thu Feb 19 09:50:51 2004
      ..  D        0  Thu Feb 19 09:50:51 2004
    45308 blocks of size 262144. 41222 blocks available
    smb: \STUJSR01_Justus-Transfer\> quit

Accessing the same subdirectory from Windows as the same user works
fine, however. Firewall is turned off. I'll attach my smb.conf, and
the file 9.log created with the above command.


Regards,

Jochen
Comment 1 Jochen Wiedmann 2004-06-06 23:52:22 UTC
Created attachment 537 [details]
smb.conf
Comment 2 Jochen Wiedmann 2004-06-06 23:52:49 UTC
Created attachment 538 [details]
Log file
Comment 3 Gerald (Jerry) Carter 2006-04-08 22:51:59 UTC
Please retest against a current release and reopen if the issue still exists.
Comment 4 Jochen Wiedmann 2006-04-10 03:21:56 UTC
Indeed, the problem is no longer present with version 3.0.22-1.fc5 (Fedora Core 5).