Bug 14222 - Software caused connection abort via GVFS
Summary: Software caused connection abort via GVFS
Status: NEW
Alias: None
Product: Samba 4.1 and newer
Classification: Unclassified
Component: libsmbclient (show other bugs)
Version: 4.10.7
Hardware: All All
: P5 normal (vote)
Target Milestone: ---
Assignee: Andrew Bartlett
QA Contact: Samba QA Contact
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-20 09:52 UTC by boongl
Modified: 2020-06-22 09:53 UTC (History)
0 users

See Also:


Attachments
GVFS SMB log file (25.23 KB, text/x-log)
2019-12-20 09:52 UTC, boongl
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description boongl 2019-12-20 09:52:56 UTC
Created attachment 15716 [details]
GVFS SMB log file

Remote files are accessed via Samba using GVFS. For some files, attempting to access the file fails with "Software caused connection abort", while for others it works correctly. The difference seems to be the size of the file.

On the client

gio mount smb://user@host/test

then

gedit smb://user@host/test/0793_TCP.txt

This fails.

File has length 172710. The client reads the entire file, then reads and gets 0 bytes, then reads again and gets the above error.

On a small file (29186 bytes) there is no error. The file is read correctly, and gedit displays the contents of the file.

I am using gedit from the command line like this to keep it simple. Normally I would be double clicking within nautilus but that gets the exact same error.

Copying the file within nautilus (CTRL/C on the file and then CTRL/V) gets the exact same error (even though it seems to work).

For a given file that fails, it seems to be 100% reproducible.

This worked with whatever versions of everything came with Ubuntu 16.04, was not working with Ubuntu 18.04 and has not worked since (currently on Ubuntu 19.10).

Original problem report against GVFS: https://gitlab.gnome.org/GNOME/gvfs/issues/438

Log file attached.