Bug 14074 - winbind offline login not working after restart / shutdown
Summary: winbind offline login not working after restart / shutdown
Status: NEW
Alias: None
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Winbind (show other bugs)
Version: 4.10.0
Hardware: All All
: P5 major (vote)
Target Milestone: ---
Assignee: Samba QA Contact
QA Contact: Samba QA Contact
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-05 18:37 UTC by Rowland Penny
Modified: 2019-08-06 11:15 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rowland Penny 2019-08-05 18:37:21 UTC
winbindd offline logon fails as required credentials stored in gencache.tdb which is wiped/recreated on startup.
Comment 1 Jeremy Allison 2019-08-05 18:38:41 UTC
Rowland, which specific released (or yet-unreleased) versions of Samba does this affect ?
Comment 2 Jeremy Allison 2019-08-05 19:03:08 UTC
Isn't the winbind offline logon cache here: winbindd_cache.tdb, not in gencache.tdb ?

I'm trying to understand the interaction with gencache.tdb here.
Comment 3 Rowland Penny 2019-08-05 19:13:39 UTC
(In reply to Jeremy Allison from comment #2)
I am not entirely sure, I have gencache.tdb in /var/cache/samba and offline logon  works (I also have netsamlogon_cache.tdb), this is on 4.8.12

Another user using 4.10.0 didn't have the files in /var/cache/samba (they are in the lock directory) and it doesn't work.
Comment 4 Louis 2019-08-06 11:15:16 UTC
Duplicate bug : https://bugzilla.samba.org/show_bug.cgi?id=13908