Bug 14017 - ctdb.service should have a condition on /etc/ctdb/nodes
ctdb.service should have a condition on /etc/ctdb/nodes
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: CTDB
4.10.5
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
: 14026 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-06-27 20:16 UTC by Rafael David Tinoco
Modified: 2019-08-09 08:10 UTC (History)
3 users (show)

See Also:


Attachments
ctdb-config-depend-on-etc-default-nodes-file.patch (1.10 KB, patch)
2019-06-27 20:16 UTC, Rafael David Tinoco
no flags Details
Patch for 4.9 and 4.10 (1.37 KB, patch)
2019-07-08 12:26 UTC, Martin Schwenke
amitay: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael David Tinoco 2019-06-27 20:16:35 UTC
Created attachment 15269 [details]
ctdb-config-depend-on-etc-default-nodes-file.patch

ctdb-config: depend on /etc/default/nodes file

    CTDB should start as a disabled unit (systemd) in most of the
    distributions and, when trying to enable it for the first time, user
    should get an unconfigured, or similar, error.

    Depending on /etc/ctdb/nodes file will give a clear direction to final
    user on what is needed in order to get cluster up and running. It should
    work like previous ENABLED=NO variables in SySV like initialization
    scripts.
Comment 1 Martin Schwenke 2019-07-03 04:50:56 UTC
Seems like a sane idea.  :-)

ConditionFileNotEmpty looks to have been around since 2013, so there don't look to be any backward compatibility issues.

CC:ing Andreas: Do you have any comments?  Just wondering, since you know systemd better than me.  :-)

Thanks...
Comment 2 Amitay Isaacs 2019-07-05 02:46:36 UTC
*** Bug 14026 has been marked as a duplicate of this bug. ***
Comment 3 Amitay Isaacs 2019-07-05 02:51:28 UTC
The bug has been assigned and it's being worked on.  There is no need to open multiple bugs for the same defect.
Comment 4 Martin Schwenke 2019-07-08 12:26:54 UTC
Created attachment 15295 [details]
Patch for 4.9 and 4.10

No CI passed here because this is packaging, which is not tested in autobuild
Comment 5 Amitay Isaacs 2019-07-09 09:52:16 UTC
Hi Karolin,

This is ready for v4-9 and v4-10.

Thanks.
Comment 6 Karolin Seeger 2019-08-06 10:37:59 UTC
(In reply to Amitay Isaacs from comment #5)
Pushed to autobuild-v4-{10,9}-test.
Comment 7 Karolin Seeger 2019-08-09 08:10:54 UTC
(In reply to Karolin Seeger from comment #6)
Pushed to both branches.
Closing out bug report.

Thanks!