Bug 14006 - bind9 crashes in dlz_bind914.so
Summary: bind9 crashes in dlz_bind914.so
Status: NEW
Alias: None
Product: Samba 4.1 and newer
Classification: Unclassified
Component: DNS plugin (BIND DLZ) (show other bugs)
Version: 4.8.12
Hardware: x64 FreeBSD
: P5 minor (vote)
Target Milestone: ---
Assignee: Amitay Isaacs
QA Contact: Samba QA Contact
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-24 13:41 UTC by tonya
Modified: 2020-09-12 00:09 UTC (History)
2 users (show)

See Also:


Attachments
gdb trace stack (3.97 KB, text/plain)
2019-06-24 13:41 UTC, tonya
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description tonya 2019-06-24 13:41:18 UTC
Created attachment 15261 [details]
gdb trace stack

I'm trying to setup samba on freebsd 12.0-RELEASE-p3 amd64 with bind_dlz backend.
I've build samba48 and bind914 with GSSAPI-heimdal from ports.

Trying to debug dns updates with samba_dnsupdate I appended a -d 9 parameter to the "dlz_bind914.so" module:
database "dlopen ...modules/bind9/dlz_bind9_14.so -d 9";
and stared named in foreground to watch the log.

But when I tried to run samba_dnsupdate, named crashed with BUS ERROR.

See attached file trace.txt from gdb debugger.

As I can see, bind crashes in dlz_bind9_14.so module when it is stared with a "-d 9" parameter.

Without such parameter (or with "-d 3") it works fine and performs updates.
Comment 1 Gary Lockyer 2019-07-18 03:08:10 UTC
Are you able to try it with
-d "9 auth_json_audit:3"
and
-d "9 auth_json_audit:4"
Comment 2 tonya 2019-07-21 09:12:13 UTC
(In reply to Gary Lockyer from comment #1)

Test 1.

Tested with such parameters in /var/db/samba4/bind-dns/named.conf:

database "dlopen /usr/local/lib/shared-modules/bind9/dlz_bind9_14.so -d 9,auth_json_audit:3";

Result: samba_dnsupdate worked, named did not crash.



Test 2.

with:

database "dlopen /usr/local/lib/shared-modules/bind9/dlz_bind9_14.so -d 9,auth_json_audit:4";

Result: samba_dnsupdate failed, named crashed with bus error.
Comment 3 tonya 2019-07-21 10:35:53 UTC
(In reply to tonya from comment #2)
answered today, see https://bugzilla.samba.org/show_bug.cgi?id=14006#c2