Bug 13899 - samba-tool domain schemaupgrade fails on DC member
samba-tool domain schemaupgrade fails on DC member
Status: RESOLVED DUPLICATE of bug 13713
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Tools
4.10.2
x64 Linux
: P5 major
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-04-16 18:47 UTC by Elias
Modified: 2019-04-17 20:44 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Elias 2019-04-16 18:47:35 UTC
Hello,

I upgrade the schema for our main ADDC and everything works properly, but the member DC (DC to an Existing AD) fails.

Both servers are in version 4.10.2

Main ADDC:

[2019/04/16 15:43:03.814846,  0] ../../source4/rpc_server/drsuapi/getncchanges.c:2919(dcesrv_drsuapi_DsGetNCChanges)
  ../../source4/rpc_server/drsuapi/getncchanges.c:2919: DsGetNCChanges 2nd replication on different DN DC=campus,DC=sertao,DC=ifrs,DC=edu,DC=br CN=Schema,CN=Configuration,DC=campus,DC=sertao,DC=ifrs,DC=edu,DC=br (last_dn CN=ms-DS-cloudExtensionAttribute14,CN=Schema,CN=Configuration,DC=campus,DC=sertao,DC=ifrs,DC=edu,DC=br)

Member DC:

[2019/04/16 15:42:55.703281,  0] ../../source4/dsdb/repl/replicated_objects.c:248(dsdb_repl_resolve_working_schema)
  Can't continue Schema load: didn't manage to convert any objects: all 1 remaining of 133 objects failed to convert
[2019/04/16 15:42:55.703619,  0] ../../source4/dsdb/repl/replicated_objects.c:361(dsdb_repl_make_working_schema)
  ../../source4/dsdb/repl/replicated_objects.c:361: dsdb_repl_resolve_working_schema() failed: WERR_INTERNAL_ERRORFailed to create working schema: WERR_INTERNAL_ERROR

Is there any way to fix this problem?

dumb question: Can I roolback the schemaupgrade? :D
Comment 1 Stefan Metzmacher 2019-04-17 20:44:41 UTC

*** This bug has been marked as a duplicate of bug 13713 ***