Bug 13845 - Samba 4.10 - Error on samba-tool with python 2.6
Samba 4.10 - Error on samba-tool with python 2.6
Status: RESOLVED DUPLICATE of bug 13837
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Python
4.10.0
x64 Linux
: P5 normal
: ---
Assigned To: Jelmer Vernooij
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-03-19 20:53 UTC by Miguel Medalha
Modified: 2019-03-19 22:17 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miguel Medalha 2019-03-19 20:53:47 UTC
With Samba 4.10 in AD-DC mode under CentOS 6.10, running "samba-tool --help" or just "samba-tool" (without parameters) produces the following error:


ERROR(<type 'exceptions.SyntaxError'>): uncaught exception - invalid syntax (uptodateness.py, line 197)
  File "/usr/local/samba/bin/samba-tool", line 45, in <module>
    retval = cmd._run("samba-tool", subcommand, *args)
  File "/usr/local/samba/lib64/python2.6/site-packages/samba/netcmd/__init__.py", line 254, in _run
    cmd = self.subcommands[cmd_name]
  File "/usr/local/samba/lib64/python2.6/site-packages/samba/netcmd/main.py", line 36, in __getitem__
    fromlist=['cmd_%s' % attr]),
  File "/usr/local/samba/lib64/python2.6/site-packages/samba/netcmd/drs.py", line 42, in <module>
    from samba.uptodateness import (
Comment 1 Andrew Bartlett 2019-03-19 22:17:56 UTC

*** This bug has been marked as a duplicate of bug 13837 ***