Bug 13844 - ERROR: Target 'gnutls' in directory ... /lib/mscat re-defined as EMPTY - was DISABLED
ERROR: Target 'gnutls' in directory ... /lib/mscat re-defined as EMPTY - was ...
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Build
4.10.0
All Linux
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-03-19 14:58 UTC by Neil MacLeod
Modified: 2019-08-06 07:41 UTC (History)
5 users (show)

See Also:


Attachments
patch for master (1.12 KB, patch)
2019-03-20 01:02 UTC, Andrew Bartlett
no flags Details
patch for 4.10 cherry-picked from master (1.09 KB, patch)
2019-06-13 21:30 UTC, Andrew Bartlett
asn: review+
abartlet: review-
Details
patch for 4.10 cherry-picked from master (1.38 KB, patch)
2019-06-27 23:35 UTC, Andrew Bartlett
dbagnall: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Neil MacLeod 2019-03-19 14:58:45 UTC
Building Samba 4.10.0 with --disabled-gnutls, and I'm experiencing the following build failure:

ERROR: Target 'gnutls' in directory /home/ubuntu/projects/LibreELEC.tv/build.LibreELEC-Generic.x86_64-9.1-devel/samba-4.10.0/lib/mscat re-defined as EMPTY - was DISABLED

This is the Samba 4.10.0 configuration: http://ix.io/1DXi

This is the complete build log for Samba: http://ix.io/1DXh

I have no issues building Samba 4.9.5 (slightly different config, of course: http://ix.io/1DXj)
Comment 1 Andrew Bartlett 2019-03-20 01:02:47 UTC
Created attachment 14954 [details]
patch for master

Merge request: https://gitlab.com/samba-team/samba/merge_requests/313
Comment 2 Neil MacLeod 2019-03-20 10:40:44 UTC
Thanks - this gets me a bit further, I'm now dealing with a cross-compile badness error building source4/heimdal that doesn't happen with 4.9.5, will open a new bug if necessary!
Comment 3 Lars Wendler 2019-03-20 15:55:41 UTC
Please keep this bug open and let the samba maintainers take care of it getting closed.
Comment 4 Neil MacLeod 2019-03-20 15:59:21 UTC
Sorry about that. Reopened.
Comment 5 Andrew Bartlett 2019-06-13 21:29:43 UTC
(In reply to Neil MacLeod from comment #4)

Merged into master as a40b0f45 for Samba 4.11 however since then GnuTLS has become mandatory.
Comment 6 Andrew Bartlett 2019-06-13 21:30:50 UTC
Created attachment 15248 [details]
patch for 4.10 cherry-picked from master
Comment 7 Andrew Bartlett 2019-06-14 05:38:48 UTC
G'Day Karolin,

Please select for the next 4.10 release.

Thanks,

Andrew Bartlett
Comment 8 Karolin Seeger 2019-06-20 09:59:28 UTC
Patch does not apply on current v4-10-test.
Re-assigning to Andrew.
Comment 9 Andrew Bartlett 2019-06-27 22:20:14 UTC
Comment on attachment 15248 [details]
patch for 4.10 cherry-picked from master

I botched the patch upload.  This is the revert I used to reproduce the error to check I was fixing it right!
Comment 10 Andrew Bartlett 2019-06-27 23:35:24 UTC
Created attachment 15270 [details]
patch for 4.10 cherry-picked from master

The forward patch for now
Comment 11 Karolin Seeger 2019-07-08 11:04:28 UTC
(In reply to Andrew Bartlett from comment #10)
Pushed to autobuild-v4-10-test.
Comment 12 Karolin Seeger 2019-08-06 07:41:11 UTC
(In reply to Karolin Seeger from comment #11)
Pushed to v4-10-test.
Closing out bug report.

Thanks!