Bug 13828 - samba-tool domain provision --interactive 'hangs'
samba-tool domain provision --interactive 'hangs'
Status: NEW
Product: Samba 4.1 and newer
Classification: Unclassified
Component: AD: LDB/DSDB/SAMDB
4.10.0rc4
All All
: P5 regression
: 4.10
Assigned To: Andrew Bartlett
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-03-10 23:51 UTC by Andrew Bartlett
Modified: 2019-03-12 04:00 UTC (History)
3 users (show)

See Also:


Attachments
patch cherry-picked from master for 4.10 (1.23 KB, patch)
2019-03-12 03:58 UTC, Andrew Bartlett
abartlet: review? (metze)
timbeale: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Bartlett 2019-03-10 23:51:53 UTC
samba-tool domain provision --interactive appears to hang as the prompt is not flushed so the administrator has no feedback that it is asking for the realm, domain and password.

As reported here:
https://lists.samba.org/archive/samba/2019-March/221753.html
Comment 1 Andrew Bartlett 2019-03-10 23:54:02 UTC
Proposed fix is here: https://gitlab.com/samba-team/samba/merge_requests/288
Comment 2 Andrew Bartlett 2019-03-12 01:45:36 UTC
I wouldn't hold the release for this, but it is technically a regression.
Comment 3 Andrew Bartlett 2019-03-12 03:58:36 UTC
Created attachment 14918 [details]
patch cherry-picked from master for 4.10

The patch is now in master and is cherry-picked here for the next available 4.10.x release.

(also manually tested)