Bug 13763 - Certain fruit:model icons not displaying on macOS 10.14.3 clients
Certain fruit:model icons not displaying on macOS 10.14.3 clients
Status: RESOLVED DUPLICATE of bug 13746
Product: Samba 4.1 and newer
Classification: Unclassified
Component: VFS Modules
4.8.4
x64 Linux
: P5 minor
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-01-25 20:19 UTC by Nate Stuyvesant
Modified: 2019-01-31 16:44 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Stuyvesant 2019-01-25 20:19:58 UTC
In the global section of smbd.conf, I've experimented with various values for fruit:model to see how the icon is displayed on macOS 10.14.3 (Mojave) clients.

These values displayed an icon specific to the model: Xserve, MacPro, iMac.
As a note, only the discontinued Mac Pro icon was displayed (the boxy one - not the cylindrical one).

These values displayed with an icon resembling an Apple Cinema Display: MacBook, MacMini, MacSamba, TimeCapsule, RackMac.

The generic icon was expected for MacSamba but not for the others.

Some unhelpful suggestions were to use values from /System/Library/CoreServices/CoreTypes.bundle/Contents/Info.plist to get specific icons.

While I didn't try every single model, most resulted in the generic icon.

Also, most people are confused about whether to specify the icon via Avahi or Samba. In fact, most examples provided show the smbd.conf setting the icon as an Xserve and the Avahi service as a MacPro.

Note: Avahi does not have issues with icon setting like Samba does.
Comment 1 Guenther Deschner 2019-01-31 16:44:34 UTC
Seems to be a duplicate of a fix we have already in master

*** This bug has been marked as a duplicate of bug 13746 ***