Bug 13754 - raspberry pi - invalid string offset for section `.strtab' during make
raspberry pi - invalid string offset for section `.strtab' during make
Status: NEW
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Build
4.10.2
Other Linux
: P5 normal
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-01-18 09:30 UTC by dariuszb
Modified: 2019-06-29 09:39 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dariuszb 2019-01-18 09:30:55 UTC
Raspberry Pi 2 running Linux DBRPi01 4.14.93-v7+ #1191 SMP Wed Jan 16 11:53:33 GMT 2019 armv7l GNU/Linux 

As in summary during compilation there are hundreds of errors like below:

/usr/bin/ld: /media/db_tc_1/Varia/Sources/samba-4.10.0rc1/bin/default/lib/param/libserver-role-samba4.so: invalid string offset 731 >= 716 for section `.strtab'
/usr/bin/ld: /media/db_tc_1/Varia/Sources/samba-4.10.0rc1/bin/default/source3/libutil-cmdline-samba4.so: invalid string offset 3862 >= 3380 for section `.strtab'
/usr/bin/ld: /media/db_tc_1/Varia/Sources/samba-4.10.0rc1/bin/default/source3/libutil-cmdline-samba4.so: invalid string offset 4028 >= 3380 for section `.strtab'
/usr/bin/ld: /media/db_tc_1/Varia/Sources/samba-4.10.0rc1/bin/default/source3/libutil-cmdline-samba4.so: invalid string offset 3848 >= 3380 for section `.strtab'
/usr/bin/ld: /media/db_tc_1/Varia/Sources/samba-4.10.0rc1/bin/default/source3/libutil-cmdline-samba4.so: invalid string offset 3863 >= 3380 for section `.strtab'
/usr/bin/ld: /media/db_tc_1/Varia/Sources/samba-4.10.0rc1/bin/default/source3/libutil-cmdline-samba4.so: invalid string offset 3874 >= 3380 for section `.strtab'
/usr/bin/ld: /media/db_tc_1/Varia/Sources/samba-4.10.0rc1/bin/default/libcli/registry/libutil-reg-samba4.so: invalid string offset 866 >= 822 for section `.strtab'
/usr/bin/ld: /media/db_tc_1/Varia/Sources/samba-4.10.0rc1/bin/default/source3/libmessages-util-samba4.so: invalid string offset 662 >= 607 for section `.strtab'
Comment 1 Norbert Hanke 2019-04-02 19:33:26 UTC
The same is true for version 4.10.0 built on Raspberry Pi 3B+ .
Comment 2 dariuszb 2019-04-03 19:36:58 UTC
(In reply to Norbert Hanke from comment #1)
Still the same for me as well. I have tried to reach samba mailing list but no answer. If you find the way to fix it let me know.
Comment 3 dariuszb 2019-04-03 19:55:33 UTC
4.10.1 the same
Comment 4 Louis 2019-04-04 08:09:06 UTC
if you could try this, use higher version of the buildtools. 

Google shows a lot of simular messages, which point to packages listed in the next line here: 
apt install -t stretch-backports devscripts cmake build-essential binutils 

# optional g++-aarch64-linux-gnu gcc-aarch64-linux-gnu

I dont have an arm setup to test this, so please try. 
but upgrading/useing the backported packages (cmake build-essential ) helps with the builds on stretch (amd64/i386) 

and optional run make without -j

Last option, you could try to use my sources and build these on arm.
Comment 5 dariuszb 2019-04-04 10:06:01 UTC
(In reply to Louis from comment #4)
I have tried - still the same.(In reply to Louis from comment #4)

thank you for suggestions. 

I have tried but without success so far but I think this is right direction.

I can't use g++-aarch64-linux-gnu gcc-aarch64-linux-gnu - as raspbian is still 32bits
Comment 6 dariuszb 2019-04-05 09:05:25 UTC
I have tried amd64/i386 platform build on debian Stretch. Clean install without any backports.

The latest Samba 4.10.1 builds without any issues. So there is no problem with mainline buildtools.

It is only something on arm.
Comment 7 Norbert Hanke 2019-06-29 09:39:48 UTC
The problem is not present when building Samba on the rpi3 running Debian Buster preview (64Bit), available from
https://people.debian.org/~gwolf/raspberrypi3/20190206/20190206-raspberry-pi-3-buster-PREVIEW.img.xz

The problem is still present when trying the same on 2019-06-20-raspbian-buster-lite (32Bit)

--> it's definitely related to the 32Bit rpi armhf/armv7l build chain