Bug 13706 - [RFE] net ads dns sub-commands should support IPv6.
Summary: [RFE] net ads dns sub-commands should support IPv6.
Status: RESOLVED FIXED
Alias: None
Product: Samba 4.1 and newer
Classification: Unclassified
Component: DNS server (internal) (show other bugs)
Version: 4.9.1
Hardware: All Linux
: P5 enhancement (vote)
Target Milestone: 4.14
Assignee: Kai Blin
QA Contact: Samba QA Contact
URL:
Keywords:
: 13473 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-12-07 12:31 UTC by Andrej Dzilský
Modified: 2020-12-23 16:30 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrej Dzilský 2018-12-07 12:31:58 UTC
Hello,

as I already mentioned in the title, net ads dns [register/unregister/gethostbyname] doesn't support IPv6 addresses.

It's weird to have IPv4/6 DNS records but not having reliable way to manage both of them.

I see that here on the Bugzilla is already reported gethostbyname not supporting IPv6: https://bugzilla.samba.org/show_bug.cgi?id=13473 , but I didn't want to write there instead I've created new report.
Comment 1 Björn Jacke 2020-12-22 20:15:42 UTC
*** Bug 13473 has been marked as a duplicate of this bug. ***
Comment 2 Samba QA Contact 2020-12-23 13:53:03 UTC
This bug was referenced in samba master:

98caa173b2471f963283bbb9d1c32ca8129f7e0b
985042d391e8124b157f21a6041ff9e17188483a
8fcde5912a966c947adf2b5b313d224c9e827ca4