Bug 1369 - the directive "write list" does not ignore the "read only" directive when "force user" is set
Summary: the directive "write list" does not ignore the "read only" directive when "fo...
Status: RESOLVED DUPLICATE of bug 1319
Alias: None
Product: Samba 3.0
Classification: Unclassified
Component: Config Files (show other bugs)
Version: 3.0.4
Hardware: All Linux
: P3 normal
Target Milestone: none
Assignee: Samba Bugzilla Account
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-05-21 02:43 UTC by Andrei Nazarenko
Modified: 2005-11-14 09:27 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Nazarenko 2004-05-21 02:43:58 UTC
Consider the following configuration section:

[htdocs]
  path = /srv/www
  valid users = +FERM
  write list = +FERM
  force user = webuser
  force group = www
  create mask = 0660
  directory mask = 0770
  browseable = No

This doesn't allow write access to anybody in FERM group, the share is 
considered to be read only by Samba 3.0.4.

Note: Samba 3.0.2a works fine with the same configuration.

For 3.0.4 to work one must add: "read only = No". Then the share is considered 
writeable. This contradicts the documentation, that states that "write list" 
directive should ignore the "read only" directive.

The "write list" DOES ignore the "read only" directive (i.e. works properly), 
if the directive "force user" is removed!

Regards,

Andrei Nazarenko
Comment 1 Gerald (Jerry) Carter 2004-05-21 11:21:56 UTC

*** This bug has been marked as a duplicate of 1319 ***
Comment 2 Gerald (Jerry) Carter 2005-11-14 09:27:54 UTC
database cleanup