Bug 13647 - copying files cifs > 1.0 causes global protection fault
copying files cifs > 1.0 causes global protection fault
Status: NEW
Product: CifsVFS
Classification: Unclassified
Component: kernel fs
3.x
x64 Linux
: P5 normal
: ---
Assigned To: Steve French
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-07 19:00 UTC by Marty Barlow
Modified: 2018-10-12 21:59 UTC (History)
1 user (show)

See Also:


Attachments
general protection fault (18.43 KB, text/plain)
2018-10-07 19:00 UTC, Marty Barlow
no flags Details
gpf from kernel 4.15.0-36-generic #39-Ubuntu (5.02 KB, text/plain)
2018-10-12 20:33 UTC, Marty Barlow
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marty Barlow 2018-10-07 19:00:55 UTC
Created attachment 14515 [details]
general protection fault

This is opening bug in samba bug tracking, originally opened under https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1777364 under ubuntu bug tracker.

Similar bug affecting archlinux https://bugs.archlinux.org/task/57474

How to reproduce:

Copy some large files from local filesystem to CIFS mounted filesystem. After some gigabytes, it syslog will show "general protection fault" and mounted file system will become unresponsive.

How often does it occur:

Every time, after a few minutes or so.

Affected kernels:

Bionic 4.15.0-23-generic and forward. I also tried 4.15.18-041518-generic and 4.16.13-041613-generic from ubuntu archives an got similar GPF.
4.13.0-43-generic from ubuntu 17.10 not affected.

More information:

I have kerberos authenticated, autofs mounted, cifs
Mounted with:
type cifs (rw,relatime,vers=default,sec=krb5,cache=strict,username=root,uid=1100,forceuid,gid=0,noforcegid,addr=192.168.50.2,file_mode=0755,dir_mode=0755,soft,nounix,serverino,mapposix,rsize=1048576,wsize=1048576,echo_interval=60,actimeo=1)

Forcing vers=1.0 forces old behavior, and does not ever have GPF

ii  samba-common                                                     2:4.7.6+dfsg~ubuntu-0ubuntu2.2              all          common files used by both the Samba server and client
ii  samba-common-bin                                                 2:4.7.6+dfsg~ubuntu-0ubuntu2.2              amd64        Samba common files used by both the server and the client
ii  samba-libs:amd64                                                 2:4.7.6+dfsg~ubuntu-0ubuntu2.2              amd64        Samba core libraries

Its easy to reproduce and very happy to provide whatever debugging information one requests.
Comment 1 Stefan Metzmacher 2018-10-07 20:09:08 UTC
This is a Bug in the Linux Kernel client not in samba.
Comment 2 Steve French 2018-10-09 05:35:36 UTC
Would you be able to try this with a more recent kernel (e.g. Ubuntu builds and packages current mainline - see http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.19-rc7/).  If that works, we can identify which fix to ask Ubuntu to backport
Comment 3 Marty Barlow 2018-10-09 19:47:17 UTC
Oh, lots more kernel minor versions to try since i last looked. I can see logs of improvements in kernel change logs.

I tried the following, and i could not recreate it.

Linux sunday 4.19.0-041900rc7-generic #201810071631 SMP Sun Oct 7 16:33:10 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

I will try kernel 4.18.0 now, which is kernel used in new 18.10 about to be released by ubuntu in a week to see if its also affected.
Comment 4 Marty Barlow 2018-10-12 20:32:15 UTC
I have been struggling to recreate on newer kernels, but here is one from 4.15.0-36-generic #39-Ubuntu

Still trying on newer kernels.
Comment 5 Marty Barlow 2018-10-12 20:33:19 UTC
Created attachment 14528 [details]
gpf from kernel 4.15.0-36-generic #39-Ubuntu

gpf from kernel 4.15.0-36-generic #39-Ubuntu
Comment 6 Marty Barlow 2018-10-12 21:59:25 UTC
I also cant reproduce on Linux sunday 4.18.0-9-generic #10-Ubuntu, which is kernel from ubuntu 18.10 (cosmic)

Sadly, 18.04 (bionic) is affected, and is long support version till April 2023

On the plus side, seems its fixed in newer version, which is great.