Bug 1363 - different md5sum on file larger than 4GB
different md5sum on file larger than 4GB
Status: RESOLVED DUPLICATE of bug 1361
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.4
All Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-18 09:03 UTC by Marco Berizzi
Modified: 2005-02-11 07:49 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Berizzi 2004-05-18 09:03:18 UTC
I'm experimenting this problem with
samba 3.0.4 and linux 2.4.26 with
ReiserFS (same behaviour with XFS).
When I copy (put) a large file (5GB)
from a Windows NT terminal server sp6a
to the samba-linux box, the md5sum is
different between the two file. Files
size are identical.
I'm using this command to copy these
files from windows to samba:

net use h: \\samba_box\backup
copy priv.edb h:\exchange

I have also tried to delete the old
files from the samba share, but nothing
change: I always get two different md5sum.
With smaller files (400MB) md5sum is
identical.
When I transfer this large file with ftp
(proftpd 1.2.9 on Linux), md5sum is ok.

These two systems are connected to a 3COM
100bit/s switch. No collision/no error are
detected at linux side box. Samba doesn't
log anything relevant. No kernel error.
Nothing. Samba box is running Slackware 9.1
+ kernel 2.4.26 + samba 3.0.4 compiled
from sources.

I have also upgraded to linux kernel
2.6.5. However this problem hasn't gone away.
The md5 check is fine, coping the same file
from NT4TSE to a Windoze 2000sp4.
Coping the same file from a windoze 2000sp4
to the samba share is ok. So the problem is
between NT4TSE and samba.

NT4TSE --> SAMBA = KO
WIN2k  --> SAMBA = OK
NT4TSE --> WIN2K = OK

Last, I have switched back to samba 2.2.8a
(compiled from source) on linux 2.6.5:
same behaviour.

Other info:
http://lists.samba.org/archive/samba/2004-May/086020.html
http://lists.samba.org/archive/samba/2004-May/086026.html
http://lists.samba.org/archive/samba/2004-May/086054.html
http://lists.samba.org/archive/samba/2004-May/086088.html
Comment 1 Gerald (Jerry) Carter 2005-02-11 07:49:15 UTC

*** This bug has been marked as a duplicate of 1361 ***