Bug 13605 - samba_dnsupdate always updates every name
samba_dnsupdate always updates every name
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: DNS server
4.9.0rc5
All All
: P5 regression
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on: 13019
Blocks:
  Show dependency treegraph
 
Reported: 2018-09-05 15:07 UTC by Björn Baumbach
Modified: 2018-09-13 09:58 UTC (History)
3 users (show)

See Also:


Attachments
fix bug 13605 (3.23 KB, patch)
2018-09-12 09:21 UTC, Björn Baumbach
bbaumbach: review+
metze: review+
metze: review? (abartlet)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Baumbach 2018-09-05 15:07:38 UTC
Since scavenging is implemented the samba_dnsupdate command always updates all dns records required by the dc.

Running the nsupdate command against the samba internal dns server shows the "TSIG error with server: tsig verify failure" error message.
These messages fill the samba log on log level 0.

I'll propose a patch on samba-technical, soon.

Björn
Comment 1 Björn Baumbach 2018-09-12 09:21:23 UTC
Created attachment 14485 [details]
fix bug 13605

The attached patch is currently still in the autobuild process, but I already did a successful private autobuild over night.

The tests on github are fine, too:
https://gitlab.com/samba-team/devel/samba/pipelines/29922237

Best regards,
Björn
Comment 2 Karolin Seeger 2018-09-13 09:20:19 UTC
Pushed to autobuild-v4-9-test.
Comment 3 Karolin Seeger 2018-09-13 09:58:55 UTC
Pushed to v4-9-test.
Closing out bug report.

Thanks!